Board index » kylix » Problem with Kylix3 and apache 2 DSO

Problem with Kylix3 and apache 2 DSO


2005-07-07 06:04:23 AM
kylix2
Hi,
I installed the Kylix etoys apache 2 units(with Dr. Bobs updates) and I
have discvered the followning 3 request properties cause a deep access
violation that a try except won't catch.
request.remoteaddr
request.remotehost
request.referer
If I comment out these lines the DSO works just the same as it does
under apache 1.x
 
 

Re:Problem with Kylix3 and apache 2 DSO

tony wrote:
Quote
Hi,
I installed the Kylix etoys apache 2 units(with Dr. Bobs updates) and I
have discvered the followning 3 request properties cause a deep access
violation that a try except won't catch.

request.remoteaddr
request.remotehost
request.referer

If I comment out these lines the DSO works just the same as it does
under apache 1.x
In the Kylix3 README is the line:
NOTE: The included Apache demos do not work with Apache 2.0
From the demos that I've looked at (not all of them) there seems to
be nothing in the code that pertains to any specific Apache version.
So, my conclusion was that HTTPD.pas was not compatible with Apache 2.
 

Re:Problem with Kylix3 and apache 2 DSO

I am using HTTPD2 which is for Apache2.
Did you miss the part about the Kylix Etoys?
Phil Henningsen wrote:
Quote
tony wrote:

>Hi,
>I installed the Kylix etoys apache 2 units(with Dr. Bobs updates) and I
>have discvered the followning 3 request properties cause a deep access
>violation that a try except won't catch.
>
>request.remoteaddr
>request.remotehost
>request.referer
>
>If I comment out these lines the DSO works just the same as it does
>under apache 1.x


In the Kylix3 README is the line:
NOTE: The included Apache demos do not work with Apache 2.0

From the demos that I've looked at (not all of them) there seems to
be nothing in the code that pertains to any specific Apache version.

So, my conclusion was that HTTPD.pas was not compatible with Apache 2.
 

{smallsort}