Board index » kylix » Kylix 3 and SuSE 10

Kylix 3 and SuSE 10


2005-10-20 07:26:19 PM
kylix1
Hi
when I try to start Kylix under SuSE 10 from the konsole via
startdelphi, I get the following error:
/home/rkrug/kylix3/bin/delphi: relocation error:
/home/rkrug/kylix3/bin/libwine.borland.so: symbol errno, version
LIBC_2.0 not defined in file libc.so.6 with link time reference
If I try to start it from the menue, nothing happes (starting icon
appears and disappears)
Does it run under SuSE 10?
Thanks
Rainer
 
 

Re:Kylix 3 and SuSE 10

Hi Rainer,
Have you tried all the settings suggested in this newsgroup in the past.
Kylix 3 should work with SUSE 10 except for the internal de{*word*81} issue.
I use SUSE 9.3
Siegfried
 

Re:Kylix 3 and SuSE 10

I put
export LD_ASSUME_KERNEL=2.4.21
in startdelphi script and it starts now. But in contrast to the small
fonts described above, I don't have any menues at all and the redraw of
the window's doesn't work at all.
Any ideas?
Rainer
siegfriedn wrote:
Quote
Hi Rainer,

Have you tried all the settings suggested in this newsgroup in the past.

Kylix 3 should work with SUSE 10 except for the internal de{*word*81} issue.
I use SUSE 9.3

Siegfried
 

{smallsort}

Re:Kylix 3 and SuSE 10

Rainer Krug wrote:
Quote
I put

export LD_ASSUME_KERNEL=2.4.21

in startdelphi script and it starts now. But in contrast to the small
fonts described above, I don't have any menues at all and the redraw of
the window's doesn't work at all.

Hi Rainer,
Have you also added
..
export LANG=en_US
..
to the appropriate place in your startdelphi script?
Good luck :)
Siegs
 

Re:Kylix 3 and SuSE 10

Brilliant
it's working now
Thanks
Rainer
siegfriedn wrote:
Quote
Rainer Krug wrote:
>I put
>
>export LD_ASSUME_KERNEL=2.4.21
>
>in startdelphi script and it starts now. But in contrast to the small
>fonts described above, I don't have any menues at all and the redraw
>of the window's doesn't work at all.
>


Hi Rainer,

Have you also added
...
export LANG=en_US
...

to the appropriate place in your startdelphi script?

--
See also the ..kylix.distros-compatibility group for more ideas.

Good luck :)

Siegs
 

Re:Kylix 3 and SuSE 10

Rainer Krug wrote:
Quote
Brilliant

it's working now

Thanks

Rainer
Does integrated debugging work ?
Isn't Suse 10 a 2.6.13 kernel?
So I guess it doesn't, just checking.
tia,
Den Jean
 

Re:Kylix 3 and SuSE 10

No, it doesn't
Den Jean wrote:
Quote
Rainer Krug wrote:

>Brilliant
>
>it's working now
>
>Thanks
>
>Rainer

Does integrated debugging work ?

Isn't Suse 10 a 2.6.13 kernel?
So I guess it doesn't, just checking.

tia,

Den Jean