Board index » delphi » BDE 4 after BDE 5.01 install

BDE 4 after BDE 5.01 install

Hi Guys,

Can anyone help me ? We have written an app against BDE 5.01 and use
installshield to install the app. This works fine untill we install another
piece of software that installs BDE 4. Our existing app fails to start, the
solution is to reinstall our app again, but this is a pain. Does anyone have
a better solution ?

TIA

Danny.

Danny Crone
dan_cr...@micro2.co.uk

 

Re:BDE 4 after BDE 5.01 install


Fix the other application's install procedure.

Re:BDE 4 after BDE 5.01 install


A certified BDE installer won't overwrite a newer version with an older one.
If an installer blindly installs the BDE without checking for an existing
newer version, there's not much you can do about it.  Just like you can't do
anything about a user that deletes the BDE directory.  You need to
re-install the newer version.

Quote
Danny Crone wrote in message <7d7pkt$k...@forums.borland.com>...
>Hi Guys,

>Can anyone help me ? We have written an app against BDE 5.01 and use
>installshield to install the app. This works fine untill we install another
>piece of software that installs BDE 4. Our existing app fails to start, the
>solution is to reinstall our app again, but this is a pain. Does anyone
have
>a better solution ?

>TIA

>Danny.

>Danny Crone
>dan_cr...@micro2.co.uk

Other Threads