Board index » delphi » Trouble Installing Quickreport 2.0k patch to Delphi 3

Trouble Installing Quickreport 2.0k patch to Delphi 3

I have recently installed Delphi 3 on my machine (Yes, I know I'm a year
behind.)  I downloaded the Quickreport 2.0k patch from the Quickreport
home page, and followed all the instructions in the Readme file.  However,
when I go into Delphi 3 I get the message "Can't load package dclqrt30.dpl.
One of the library files needed to run the application can not be found."
So I removed Quickreport from the package list under Components | Install
packages.  The Readme file said I should re-register it.  How do I do
that?  All the Delphi documentation says about registering is what to
put in the source file.

I get that error message when I try to add dclqrt30.dpl.
Did I miss something?  I just started trying out Delphi 3, and I don't
quite understand packages yet.  When I tried to do Components |
Install, it wanted a .pas or .dcu file.

I downloaded and installed the Delphi 3.02 patch to my original Delphi
3.01.  That didn't help.

Luckily I kept a copy of all the Quickreport 2.0b files.

Can somebody please help me?

Sue Sarlette

 

Re:Trouble Installing Quickreport 2.0k patch to Delphi 3


I'm also trying to install the update QR20K from the QuSoft site.  There are
QRPT30.DCP and QRPT30.DCU files but where is the QRPT30.DPL file??

I notice that there is a DCLQRT30.DPL file included.  Is this given instead?

I obviously don't know enough about packages,  but even so I can't seem to
see how the upgrade works... does anyone have any proper instructions as the
ones in the Readme file weren't enough for me.

Quote
Sue Sarlette wrote in message <6ri4j9$27...@forums.borland.com>...
>I have recently installed Delphi 3 on my machine (Yes, I know I'm a year
>behind.)  I downloaded the Quickreport 2.0k patch from the Quickreport
>home page, and followed all the instructions in the Readme file.  However,
>when I go into Delphi 3 I get the message "Can't load package dclqrt30.dpl.
>One of the library files needed to run the application can not be found."
>So I removed Quickreport from the package list under Components | Install
>packages.  The Readme file said I should re-register it.  How do I do
>that?  All the Delphi documentation says about registering is what to
>put in the source file.

>I get that error message when I try to add dclqrt30.dpl.
>Did I miss something?  I just started trying out Delphi 3, and I don't
>quite understand packages yet.  When I tried to do Components |
>Install, it wanted a .pas or .dcu file.

>I downloaded and installed the Delphi 3.02 patch to my original Delphi
>3.01.  That didn't help.

>Luckily I kept a copy of all the Quickreport 2.0b files.

>Can somebody please help me?

>Sue Sarlette

Re:Trouble Installing Quickreport 2.0k patch to Delphi 3


Quote
Sue Sarlette wrote:

> I have recently installed Delphi 3 on my machine (Yes, I know I'm a year
> behind.)  I downloaded the Quickreport 2.0k patch from the Quickreport
> home page, and followed all the instructions in the Readme file.  However,
> when I go into Delphi 3 I get the message "Can't load package dclqrt30.dpl.
> One of the library files needed to run the application can not be found."
> So I removed Quickreport from the package list under Components | Install
> packages.  The Readme file said I should re-register it.  How do I do
> that?  All the Delphi documentation says about registering is what to
> put in the source file.

> I get that error message when I try to add dclqrt30.dpl.
> Did I miss something?  I just started trying out Delphi 3, and I don't
> quite understand packages yet.  When I tried to do Components |
> Install, it wanted a .pas or .dcu file.
> Can somebody please help me?

I suspect you have not correctly followed the instructions in the
readme, which said:

- If you use Windows 95 then copy all files in the newly created
  QUICKREP\DELPHI3\SYSTEM directory to your WINDOWS\SYSTEM directory
- If you use Windows NT then copy all files in the newly created
  QUICKREP\DELPHI3\SYSTEM directory to your WINNT\SYSTEM32 directory.
Also make
  sure you have service pack 3 installed

Now the file in the system directory is QRPT30.DPL, and the system
directory should be in your path.  So if you have not put it into the
system directory, then your program will not function.

You should probably do a reinstall of the quickrep package and ensure
you exactly follow the instructions (check dates of files before and
after you move them).

I have had no problem installing 2.0k.

Oliver

Other Threads