Board index » delphi » Not Initialized for Accessing Network?

Not Initialized for Accessing Network?

I have a Delphi 1.0 Application running on a lantastic network.  I am
using
paradox tables.  When I set up the client machine with the BDE and try to
execute the application off the server I get a message Not Initialized
for Accessing Network.  The App and files are all on the server in one
directory.
The Application creates TTables and TQuerys and sets the DatabaseName
equal to the same path as the EXE.  I have tried the more things than I
can mention in this post.  It must be something simple because I cant
image it would be this difficult to get this working.   I did try setting
both BDE to the same path for NetFile and I set local share to true.  
When I do this I can no longer run on the server, I get some  Multiple
LCK message.  Thanks in advance.

Michael.

MichaelCr...@prodigy.com

 

Re:Not Initialized for Accessing Network?


Quote
Michael Crown wrote:

> I have a Delphi 1.0 Application running on a lantastic network.  I am
> using
> paradox tables.  When I set up the client machine with the BDE and try to
> execute the application off the server I get a message Not Initialized
> for Accessing Network.  The App and files are all on the server in one
> directory.
> The Application creates TTables and TQuerys and sets the DatabaseName
> equal to the same path as the EXE.  I have tried the more things than I
> can mention in this post.  It must be something simple because I cant
> image it would be this difficult to get this working.   I did try setting
> both BDE to the same path for NetFile and I set local share to true.
> When I do this I can no longer run on the server, I get some  Multiple
> LCK message.  Thanks in advance.

> Michael.

> MichaelCr...@prodigy.com

 Hi
I had the same problem
Turned out you have to set your 'Netdir 'path in the BDE Config to where
your pdoxusrs.net is (this file is needed for record locking in your
network)
J Burger
rek12 @elsburg1.agric.za

Re:Not Initialized for Accessing Network?


Quote
NBVT...@prodigy.com (Michael Crown) wrote:
>I have a Delphi 1.0 Application running on a lantastic network.  I am
>using
>paradox tables.  When I set up the client machine with the BDE and try to
>execute the application off the server I get a message Not Initialized
>for Accessing Network.  The App and files are all on the server in one
>directory.
>The Application creates TTables and TQuerys and sets the DatabaseName
>equal to the same path as the EXE.  I have tried the more things than I
>can mention in this post.  It must be something simple because I cant
>image it would be this difficult to get this working.   I did try setting
>both BDE to the same path for NetFile and I set local share to true.  
>When I do this I can no longer run on the server, I get some  Multiple
>LCK message.  Thanks in advance.
>Michael.
>MichaelCr...@prodigy.com

You didn't mention which version of Lantastic you were using, but if I
recall correctly, it is a known and reported bug the BDE is
incompatible with certain versions of Lantastic (version 5?). Check
out the Borland Web site for more info.

Hope this helps.

Regards,

Jani J?rvinen
Helsinki Finland
ja...@xgw.fi

Re:Not Initialized for Accessing Network?


Quote
> You didn't mention which version of Lantastic you were using, but if I
> recall correctly, it is a known and reported bug the BDE is
> incompatible with certain versions of Lantastic (version 5?). Check
> out the Borland Web site for more info.

That's right, if go to the Borland's Web pages and download the newer
version of BDE, your app will work perfectly. I had a same problem, but
it solved after updating BDE.

Greets,

Ville Virtanen
Virtual Magic Inc.

Other Threads