Board index » delphi » IdHTTP Timeout # 10060 on Get ( v 9.0.2-B )

IdHTTP Timeout # 10060 on Get ( v 9.0.2-B )

Does anyone else have a problem with an exception 10060 (timeout) when doing
a Get on a web page.
Only happens on some machines, and so far I can't pinpoint anything strange
about the machines where it fails.

The following are the sequence of status messages from a machine that fails.

Status Connecting to 123.123.123.123 <<<--- any IP
Status Disconnecting.   <<<--- when the Get works, this is a Connect, not a
disconnect
Disconnected
Status Disconnected.
Socket Error 10060 ::   A connection attempt failed because the connected
party did not properly respond after a period of time, or established
connection failed because connected host has failed to respond.
Error Socket Error # 10060
Connection timed out.

I have tried changing the ReadTimeout property up to 60 seconds and it does
not help.

any help greatly appreciated

jack kenyon

 

Re:IdHTTP Timeout # 10060 on Get ( v 9.0.2-B )


Try this with 9.0.3
If the same problem persists then just make a bug report to the Indy bug
report system

Doychin

Quote
"Jack Kenyon" <jken...@bigpond.net.au> wrote in message

news:3c6a5c87_2@dnews...
Quote
> Does anyone else have a problem with an exception 10060 (timeout) when
doing
> a Get on a web page.
> Only happens on some machines, and so far I can't pinpoint anything
strange
> about the machines where it fails.

> The following are the sequence of status messages from a machine that
fails.

> Status Connecting to 123.123.123.123 <<<--- any IP
> Status Disconnecting.   <<<--- when the Get works, this is a Connect, not
a
> disconnect
> Disconnected
> Status Disconnected.
> Socket Error 10060 ::   A connection attempt failed because the connected
> party did not properly respond after a period of time, or established
> connection failed because connected host has failed to respond.
> Error Socket Error # 10060
> Connection timed out.

> I have tried changing the ReadTimeout property up to 60 seconds and it
does
> not help.

> any help greatly appreciated

> jack kenyon

Re:IdHTTP Timeout # 10060 on Get ( v 9.0.2-B )


Jack,

I rand across same problem, set:

  ReceiveTimeout := 10000{ms};

before the .Get.

Regards

Keith

Re:IdHTTP Timeout # 10060 on Get ( v 9.0.2-B )


It is fixed now.

Doychin Bondzhev - Team Indy

Quote
"Jack Kenyon" <jken...@bigpond.net.au> wrote in message

news:3c6a5c87_2@dnews...
Quote
> Does anyone else have a problem with an exception 10060 (timeout) when
doing
> a Get on a web page.
> Only happens on some machines, and so far I can't pinpoint anything
strange
> about the machines where it fails.

> The following are the sequence of status messages from a machine that
fails.

> Status Connecting to 123.123.123.123 <<<--- any IP
> Status Disconnecting.   <<<--- when the Get works, this is a Connect, not
a
> disconnect
> Disconnected
> Status Disconnected.
> Socket Error 10060 ::   A connection attempt failed because the connected
> party did not properly respond after a period of time, or established
> connection failed because connected host has failed to respond.
> Error Socket Error # 10060
> Connection timed out.

> I have tried changing the ReadTimeout property up to 60 seconds and it
does
> not help.

> any help greatly appreciated

> jack kenyon

Other Threads