Board index » delphi » Delphi 2.0 Update - Problems with the new BDE that comes with the update

Delphi 2.0 Update - Problems with the new BDE that comes with the update

Hi ! I have just installed the Delphi 2.0 Upgrade and recompile my
programs. At the first look , it was OK. Finally I saw that when I had new
record in a specific table, my TDBGrid does not recongnize those new
record (only the new ones). If I use the Database Desktop, I can see the
new records. I had to reinstalled the previous Delphi 2.0 version (the
original one) to use the old BDE. and the records now appears in my
TDBGrid. No codes were added or changed at all !. I know that it is the
BDE because I sent an InstallShield diskette to install only the BDE and I
realize that installing the BDE from the original Delphi 2.0 bring every
things back working (even with the same .EXE files compiled with Delphi
2.0 upgrade. We use PARADOX 5.0 structure (builded from Database Desktop)

Please Help!

 

Re:Delphi 2.0 Update - Problems with the new BDE that comes with the update


In article: <511sb7$...@cti01.citenet.net>  Luc Brodeur <lbrod...@citenet.net> writes:

Quote

> Hi ! I have just installed the Delphi 2.0 Upgrade and recompile my
> programs. At the first look , it was OK. Finally I saw that when I had new
> record in a specific table, my TDBGrid does not recongnize those new
> record (only the new ones). If I use the Database Desktop, I can see the
> new records.
[snip]
> We use PARADOX 5.0 structure (builded from Database Desktop)

I can confirm this problem. (I originally thought it was an error
in my program.)

BTW: The AppendRecord/InsertRecord methods are also faulty in
that they do not call the OnPostError event if there is a post error.
(They do call BeforePost and AfterPost.)

--
Chris Isbell               Southampton, England
ch...@kenda.co.uk (work)   ch...@isbell.demon.co.uk (home)
+44 1703 869922            +44 1703 465367

Other Threads