Board index » delphi » BDE error: bad file number

BDE error: bad file number

I have an app that has been getting 'bad file number' errors on a daily
basis.  It generally happens when a user is typing in a DBMemo component
that is linked to a memo field in a Paradox table.  Sometimes the app
locks up, sometimes win95 locks up altogether.  What can cause this
error?

This seems to happen every morning.  I've used dtutil32 to rebuild all
of the tables and the app works fine for the rest of the day.  Sometimes
I don't even have to use dtuil32 and the app will run fine for the rest
of the day.

This is a multi-user environment with Paradox tables.  All users have
Local Share set to True and have the same Net Dir.  The app was written
with D3.02.

The day before these troubles started I restructured one of the tables
to remove an unused memo field and descreased the size of 2 string
fields and 1 memo field.  The corresponding instantiated fields in the
app were adjusted accordingly.  I suspect that this restructuring may
have caused the problems, but I can't figure out why.  Is there any good
way to fix the error?

Thanks,
Neal
n...@mi-assistant.com

 

Re:BDE error: bad file number


Quote
>This is a multi-user environment with Paradox tables.  All users have
>Local Share set to True and have the same Net Dir.  The app was written
>with D3.02.

The only circumstances I have heard of where this comes up are insufficient file
handles and network errors.

--
Brian Bushay (TeamB)
Bbus...@DataGuidance.com

Other Threads