build IB on Solaris 8 x86 edition

I've got a problem when I built IB source on Solaris 8 x86 Edition. It needs
a precompiled IB runtime, but there is no such one. I tried to use IB linux
runtime, but I got a ld error, it can't find ld-linux.so.2. So I put a
ld-linux.so.2 in the lib folder, but I got segement fault.

What should I do? Is it possible to use IB in Sol8 x86?

Anyone can help me? Thanks