Board index » delphi » ParamByName doesn't works?

ParamByName doesn't works?

Hi, i want to know if there are limitations or malfunction of the
ParamByName property of Delphi using ADO.
thanks
--
Guillermo Casta?o Acevedo <SIRIO>
Guiller...@GrupoMillennium.com
Guillermo...@Hotmail.com
WWW: http://www.GrupoMillennium.com (Gerente de Sistemas)
Systems and Computers Engineer
 

Re:ParamByName doesn't works?


Quote
> Hi, i want to know if there are limitations or malfunction of the
> ParamByName property of Delphi using ADO.

I haven't had problems with that so fare.

--
Vassil Nazarov
http://web.orbitel.bg/vassil/

Re:ParamByName doesn't works?


I have had problems using parambyname.
I switched to using params instead
use it like this
TADOQuery1.params[0].value := SomeValue;

HTH
Ross

Re:ParamByName doesn't works?


It fixed with the ADOExpress upgrade

Quote
Vassil Nazarov wrote:
> > Hi, i want to know if there are limitations or malfunction of the
> > ParamByName property of Delphi using ADO.

> I haven't had problems with that so fare.

> --
> Vassil Nazarov
> http://web.orbitel.bg/vassil/

--
Guillermo Casta?o Acevedo <SIRIO>
Guiller...@GrupoMillennium.com
Guillermo...@Hotmail.com
WWW: http://www.GrupoMillennium.com (Gerente de Sistemas)
Systems and Computers Engineer

Re:ParamByName doesn't works?


Quote
> i want to know if there are limitations or malfunction of the
>ParamByName property of Delphi using ADO.

Do not use the same parameter name more than once in your SQL
--
Brian Bushay (TeamB)
Bbus...@NMPLS.com

Other Threads