Board index » delphi » Q: Problems with VB and Delphi using a VB-ActiveX

Q: Problems with VB and Delphi using a VB-ActiveX

Hello,
    yesterday we tried to test an ActiveX in Delphi 4.02 which was written
in  VB (6.0).

We encounterd a strange  phenomenon:

- We imported the tlb and compiled it to a new package -> ok
- designed a from with the ActiveXs -> ok
- setting/getting properties at the ActiveX -> ok
- using events of the ActiveX ->ok

- call any of the method -> BOOM
- making a latebound variable of myObject->ControlInterface and call the
methods -> OK

Anybody having an idea what going on ?

with best regards and greetings from Cologne
    Chris

--
greetings from Cologne
    Chris

 

Re:Q: Problems with VB and Delphi using a VB-ActiveX


Hi Chris,

hmmm, We had lots of similar problems it turned out to be variant type
problems caused by the import util, are there any params declared like so VB
(items() as variant)

Royboy,....  I will need a copy to help ya further mate. Ps do ya want to do
a swap, ive got some nice ones.

Quote
Chris Gnther wrote in message <77prh8$4k...@forums.borland.com>...
>Hello,
>    yesterday we tried to test an ActiveX in Delphi 4.02 which was written
>in  VB (6.0).

>We encounterd a strange  phenomenon:

>- We imported the tlb and compiled it to a new package -> ok
>- designed a from with the ActiveXs -> ok
>- setting/getting properties at the ActiveX -> ok
>- using events of the ActiveX ->ok

>- call any of the method -> BOOM
>- making a latebound variable of myObject->ControlInterface and call the
>methods -> OK

>Anybody having an idea what going on ?

>with best regards and greetings from Cologne
>    Chris

>--
>greetings from Cologne
>    Chris

Re:Q: Problems with VB and Delphi using a VB-ActiveX


Hello,

If you have the VB source, you should be able to debug it from the VB IDE
while Delphi is hosting the control.

have fun
--
Binh Ly
Brickhouse Data Systems, Inc.
http://www.brickhouse.com

Quote
Chris Gnther wrote in message <77prh8$4k...@forums.borland.com>...
>Hello,
>    yesterday we tried to test an ActiveX in Delphi 4.02 which was written
>in  VB (6.0).

>We encounterd a strange  phenomenon:

>- We imported the tlb and compiled it to a new package -> ok
>- designed a from with the ActiveXs -> ok
>- setting/getting properties at the ActiveX -> ok
>- using events of the ActiveX ->ok

>- call any of the method -> BOOM
>- making a latebound variable of myObject->ControlInterface and call the
>methods -> OK

>Anybody having an idea what going on ?

>with best regards and greetings from Cologne
>    Chris

>--
>greetings from Cologne
>    Chris

Re:Q: Problems with VB and Delphi using a VB-ActiveX


On Sat, 16 Jan 1999 12:14:13 +0100, "Chris Gnther"

Quote
<chr...@netcologne.de> wrote:
>Hello,
>    yesterday we tried to test an ActiveX in Delphi 4.02 which was written
>in  VB (6.0).

>We encounterd a strange  phenomenon:

>- We imported the tlb and compiled it to a new package -> ok
>- designed a from with the ActiveXs -> ok
>- setting/getting properties at the ActiveX -> ok
>- using events of the ActiveX ->ok

>- call any of the method -> BOOM

I've got the *exact* same problem! Glad to know I'm not alone!

Quote
>- making a latebound variable of myObject->ControlInterface and call the
>methods -> OK

Haven't tried this yet. I guess I'll try tonight and see what it does.

Quote
>Anybody having an idea what going on ?

>with best regards and greetings from Cologne
>    Chris

>--
>greetings from Cologne
>    Chris

Cary D. Beuershausen
Senior Systems Consultant

Other Threads