Board index » delphi » D4 not running on Win98

D4 not running on Win98

Please, help me. I install Delphi 4.0 on Windows'98. Delphi hangs at
very beginning, without entering.
Alexandre
PC, 266 MHz, 32 MB RAM, 4MB Video Memory
 

Re:D4 not running on Win98


Some of the video drivers for win98 are very buggy (S3 being the worse).  

try

1) Get the latest driver (www.s3.com or your vendor) If you have an S3
chipset.
2) Start Delphi with the -ns switch
3)  Under the [display] section of the SYSTEM.INI file
add the following line
    BusThrottle=1
4) play with color depth/resolution  1024x768 in 16 bit color seems the
worse.
5) reduce the hardware acceleration for the card.
6) Get the latest DirectX drivers. (probably not needed for Win98 systems)
7) one person has found that no desktop wallpaper or a wallpaper that is
smaller in size worked for him.

Jeff Overcash

In article <35E1EC63.802...@pop-ac.rnp.br>, "Alejandro A. Fonseca Duarte"

Quote
<alejan...@pop-ac.rnp.br> wrote:
>Please, help me. I install Delphi 4.0 on Windows'98. Delphi hangs at
>very beginning, without entering.
>Alexandre
>PC, 266 MHz, 32 MB RAM, 4MB Video Memory

Re:D4 not running on Win98


Alejandro,

Your problem is most likely a conflict with your video card driver.  You can
test this by going to your Display control panel, click on the "Settings" tab,
click on the "Advanced Properties" button near the bottom, click on the "Driver"
tab, and then move the slider that says "Hardware Acceleration" all the way to
the left.  Restart your computer and try to run Delphi.

For a permanent solution, try to get the latest driver from your video card's
manufacturer or use a Microsoft video driver.

--
------------------------
Richard
Delphi Developer Support
www.inprise.com
(I do not respond to support questions by e-mail)

Re:D4 not running on Win98


Turning off hardware acceleration didn't help for me and upgrading to the
latest video driver didn't help either.  Everything else I've tried, I've
been able to install, including Office and ERwin.  Only D4 has install
problems.

Bill Hamilton
Hamilt...@syncor.com

Re:D4 not running on Win98


Try setting the [Display] section of the system.ini file to:
BusThrottle = 1

It may work - but then again, it just may be another way of turning off
hardware acceleration.

------------------------
Ralph Dean Pruitt
ra...@pruitt.demon.co.uk
------------------------

Quote
Bill Hamilton wrote:

> Turning off hardware acceleration didn't help for me and upgrading to the
> latest video driver didn't help either.  Everything else I've tried, I've
> been able to install, including Office and ERwin.  Only D4 has install
> problems.

> Bill Hamilton
> Hamilt...@syncor.com

Re:D4 not running on Win98


Bill,

Could you describe your symptoms.  What graphics card do you have?  Did you get
any error messages during installation?  Have you tried starting Delphi with the
-ns command line option?  When you say you used the latest drivers, did you get
the latest drivers from your card's manufacturer or did you use the ones on the
Windows 98 CD?

--
------------------------
Richard
Delphi Developer Support
www.inprise.com
(I do not respond to support questions by e-mail)

Re:D4 not running on Win98


Tried it and didn't work either.  Thanks for the reply just the same!

Bill
Hamilt...@syncor.com

Re:D4 not running on Win98


My machine is a 400mhz, 128RAM, Permedia 2 3D Accelerator video card by
3DLabs, Liteon CD-ROM.  I downloaded and installed the latest video driver
from 3DLabs.  I can't get D4 to install.  The initial screen, where you
have the option to install D4, Interbase, Remote Debugging, etc, comes up
fine.  Selecting any of the options and the cdrom drive spins, the busy
cursor appears, for appx. 20 seconds, then without any message, the system
returns to allowing selection from the initial screen.

I've turned hardware acceleration off, set BusThrotte = 1, downloaded
latest drivers, reset video mode to various modes, all with the same
results.

Thanks,
Bill
Hamilt...@syncor.com

Richard [Inprise] <supporti...@inprise.com> wrote in article
<35EC169C.F1EA3...@inprise.com>...

Quote
> Bill,

> Could you describe your symptoms.  What graphics card do you have?  Did
you get
> any error messages during installation?  Have you tried starting Delphi
with the
> -ns command line option?  When you say you used the latest drivers, did
you get
> the latest drivers from your card's manufacturer or did you use the ones
on the
> Windows 98 CD?

> --
> ------------------------
> Richard
> Delphi Developer Support
> www.inprise.com
> (I do not respond to support questions by e-mail)

Re:D4 not running on Win98


Bill,

It does not appear that you have a video driver related problem.  You may have a
damaged or dirty CD.  Check the bottom of your CD for any grease splotches or
serious scratching.  If you can see something, try cleaning the CD.  If you
can't see anything, see if you can install Delphi on another computer to verify
whether or not the CD works.  Please post back with your results.
--
------------------------
Richard
Delphi Developer Support
www.inprise.com
(I do not respond to support questions by e-mail)

Re:D4 not running on Win98


So, I have %^$* for brains.  I never suspected the CD.  Checking the CD, I
noted that there were a couple of spots I couldn't clean off.  I obtained
another copy of D4 and installed without any problems.

Thanks for the help!
Bill Hamilton
Hamilt...@syncor.com

Other Threads