Board index » delphi » Running App in D5-IDE freezes my W95 system

Running App in D5-IDE freezes my W95 system

Hello Team B,

This week I installed D5 prof / German Edition (Build 5.62) and CBuilder
4 prof / German Edition (Build 14.4) on my Machine (Windows 95 B
(German)/ 4.00.950 B , 64  MB Ram, Cyrix 6x86 MX , Graphic: Hercules
Dynamite 3D/GL (Permedia) with 4 MB, running at 1152*870 and 32 Bit
Color depth).
First I wanted to try out the new Delphi  IDE, so I first chose a new
Application from the gallery. (I didnt add any code). While I run this
App inside the IDE (or do Single-stepping) and then try to switch to
another Application (ALT+TAB), the Task-Switching Window doesn t appear
and the system stops working. I can only move the mouse further on, and
after some movements every mouse movement comes with Clicks in the PC
speaker. I then tried to shoot off D5 by Ctrl+Alt+Del (knowing that the
system is probably Braindead, but nevertheless) the W95 Close
Application window comes up and stays there but i cant do any action
there. At this stage i can go on moving the mouse, but there is no noise
in the speaker any more.When i press Ctrl+Alt+Del again, the System
reboots without any disk-checking.
When the App runs in the IDE, i can switch to other applications (and
back) by choosing it from the taskbar, without freezing the system,
until i use Alt+Tab.
My new CBuilder 4 behaves exactly the same way. Delphi 3 prof and D2
prof, which are on the same machine, work fine. There is an 3 year old
installation of Borland C++ 5.0, but i dont think that there is any
influence from this corner.
I spoke with the german Inprise support, but they couldnt offer me a
solution. They said that i should try to reduce color depth and
resolution (because of ressource problems), so i tried with 800*600 /16
Bit but there was no change in the behavior. The W95 res-monitor didnt
indicate any res problems, too.

I hope you can give me some Hints what i could try to do.
How can i try to encircle the  problem ?

Andreas

 

Re:Running App in D5-IDE freezes my W95 system


Hello Team B,

I did some tries to encircle the problem i wrote 2 days ago. When i
uncheck De{*word*81}Options / Event Log / Window Messages, the problem
disappears (both in D5 and CB4). Whats going on here ? Is my Computer
too slow to create a log for the Windows Messages ? Can I make it
working somehow ?
First I thought the Problem would be caused by a faulty installation
(therefore i posted here)
Seems now as it would be an IDE / De{*word*81} -related Problem.

Andreas

Re:Running App in D5-IDE freezes my W95 system


I normally keep that unchecked because it does greatly slow down my machine (a
P450 256 MB).  

Quote
Andreas Wipfler wrote:

> Hello Team B,

> I did some tries to encircle the problem i wrote 2 days ago. When i
> uncheck De{*word*81}Options / Event Log / Window Messages, the problem
> disappears (both in D5 and CB4). Whats going on here ? Is my Computer
> too slow to create a log for the Windows Messages ? Can I make it
> working somehow ?
> First I thought the Problem would be caused by a faulty installation
> (therefore i posted here)
> Seems now as it would be an IDE / De{*word*81} -related Problem.

> Andreas

--
Jeff Overcash (TeamB)
      (Please do not email me directly unless  asked. Thank You)
Live never to be ashamed if anything you do or say is published around the world
- even if what is published is not true.    (R Bach)

Re:Running App in D5-IDE freezes my W95 system


In message <38652D59.A5898...@AOL.de>, Andreas Wipfler stated:
Quote
> Whats going on here ? Is my Computer
> too slow to create a log for the Windows Messages ? Can I make it
> working somehow ?

Andreas,

logging every Windows message is going to give you a performance hit.
Use it only when you really need it.

--
Regards
Ralph (TeamB)
--

Re:Running App in D5-IDE freezes my W95 system


"Ralph Friedman (TeamB)" schrieb:

Quote

> logging every Windows message is going to give you a performance hit.
> Use it only when you really need it.

> --
> Regards
> Ralph (TeamB)
> --

Performance isnt the Problem. Message logging is working right until i
use ALT+TAB
to switch to another App. In opposition to that, using the mouse to
select
another Apps Window doesnt cause the problem.

Andreas

Re:Running App in D5-IDE freezes my W95 system


In message <386AC948.FE0DA...@AOL.de>, Andreas Wipfler stated:
Quote
> Performance isnt the Problem. Message logging is working right until i
> use ALT+TAB
> to switch to another App. In opposition to that, using the mouse to
> select
> another Apps Window doesnt cause the problem.

Andreas,

sorry, but I can't reproduce the effect that you're reporting.
--
Regards
Ralph (TeamB)
--

Other Threads