Board index » delphi » Need help connecting to Oracle 9 w/ Delphi 7 Enterprise: BDE error 15897 Vendor Initialization failed

Need help connecting to Oracle 9 w/ Delphi 7 Enterprise: BDE error 15897 Vendor Initialization failed

* Delphi 7 Enterprise

* Oracle 9 client and server.  The database is on a different computer
than the one from which I'll be developing Delphi code.

* I've verified that I have access to the Oracle 9 database.  I can
connect using SQL*Plus using my username, password, and server name.
SQL*Plus says "Release 9.2.0.1.0 - Production".

* Windows XP is on the client system; I'm not sure if the Oracle server
system is Windows NT or XP.

* Driver - Oracle (not the ODBC driver from Oracle)

* Oracle 8 also happens to be installed on the client system, but the
database is on an Oracle 9 server, so I'm using Oracle 9

Here's what is happening:

I start BDE Admin.  I select "Object | New".

I enter "Oracle" as the Database Driver Name & click button to create alias.

I changed the name of the alias to TEST.

I put my username (the same one I used when I connected via SQL*Plus
above) in the User Name slot in the right window pane, Definition.

I put the server name in the Server Name slot - the same one I used when
I connected via SQL*Plus above.

I saved my changes to the TEST alias by clicking on the blue arrow (Apply)

I attempted to open the TEST alias by clicking on the +, or by double
clicking.  I get this message:

Connect: Vendor initialization failed. Alias: TEST
BDE Error 15879 [$3e][$ 7]

WHAT AM I DOING WRONG?

Do I need to configure the ORACLE driver in BDE on the configuration tab
first?  If so, what do I update?

This error message from the BDE is not at all helpful.

thank you in advance for you help.

 

Re:Need help connecting to Oracle 9 w/ Delphi 7 Enterprise: BDE error 15897 Vendor Initialization failed


If this is a new project and you're not tied to the BDE, I strongly
recommend that you use something else. Either DOA or ODAC.

http://www.allroundautomations.nl/
http://crlab.com/odac/

--

Alain Quesnel
alainqsanss...@compuserve.com

Quote
"Linda Murphy" <kotod...@juno.com> wrote in message

news:3e948f65@newsgroups.borland.com...
Quote
> * Delphi 7 Enterprise

> * Oracle 9 client and server.  The database is on a different computer
> than the one from which I'll be developing Delphi code.

> * I've verified that I have access to the Oracle 9 database.  I can
> connect using SQL*Plus using my username, password, and server name.
> SQL*Plus says "Release 9.2.0.1.0 - Production".

> * Windows XP is on the client system; I'm not sure if the Oracle server
> system is Windows NT or XP.

> * Driver - Oracle (not the ODBC driver from Oracle)

> * Oracle 8 also happens to be installed on the client system, but the
> database is on an Oracle 9 server, so I'm using Oracle 9

> Here's what is happening:

> I start BDE Admin.  I select "Object | New".

> I enter "Oracle" as the Database Driver Name & click button to create
alias.

> I changed the name of the alias to TEST.

> I put my username (the same one I used when I connected via SQL*Plus
> above) in the User Name slot in the right window pane, Definition.

> I put the server name in the Server Name slot - the same one I used when
> I connected via SQL*Plus above.

> I saved my changes to the TEST alias by clicking on the blue arrow (Apply)

> I attempted to open the TEST alias by clicking on the +, or by double
> clicking.  I get this message:

> Connect: Vendor initialization failed. Alias: TEST
> BDE Error 15879 [$3e][$ 7]

> WHAT AM I DOING WRONG?

> Do I need to configure the ORACLE driver in BDE on the configuration tab
> first?  If so, what do I update?

> This error message from the BDE is not at all helpful.

> thank you in advance for you help.

Other Threads