Board index » delphi » INDEX ERROR in NT-Networks using Paradox-DB′s

INDEX ERROR in NT-Networks using Paradox-DB′s

Hello All,

I have the following problem:

we wrote a programm using Paradox Databases. In Novell-networks
we have no problem running the program.
In NT-Networks (NT4.0 SP3) we get sometimes INDEX-Errors, but only in
networks with more than 3 workstations. Does anyone know this Problem?
Please answere!

Thanks

Jrgen Bucher
--
_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-
Fuessl und Bucher
                 SOLUTIONS for a WIDE WORLD
                                            call 0049-731-710666

 

Re:INDEX ERROR in NT-Networks using Paradox-DB′s


Hi everyone,
Hi Jrgen
If you are a problem with Paradox Tables
You must declare a "NET DIR" global for anyone workstation in the BDE
administrator.
By example :
    the local dir (for nt) is d:\soft\data where the tables are present,
shared the  directory
    Every workstation are a logical disk to NT , by example "U: to
d:\soft\data"
    The BDE "NET DIR" will be "U:\"
    BDE will strore the "pdoxuser.net" file for a good share ...

Excuse me for a "little english"
Bon courage ...;-)

Reynald Valle
cante...@normandnet.fr

Juergen Bucher a crit dans le message <65tqht$te...@news00.btx.dtag.de>...

Quote
>Hello All,

>I have the following problem:

>we wrote a programm using Paradox Databases. In Novell-networks
>we have no problem running the program.
>In NT-Networks (NT4.0 SP3) we get sometimes INDEX-Errors, but only in
>networks with more than 3 workstations. Does anyone know this Problem?
>Please answere!

>Thanks

>Jrgen Bucher
>--
>_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-
>Fuessl und Bucher
>          SOLUTIONS for a WIDE WORLD
>            call 0049-731-710666

Re:INDEX ERROR in NT-Networks using Paradox-DB′s


Juergen:

Assuming you have the network set up correctly, there is a known problem
with the NT system - you can get a dlayed write from the file cache,
causing sometines sever users - the more users, the worse the problem.

We have an article on our Components page - "Delphi & Networks" with
lots of information.

It has an "OPLOCKS" section telling how to deal with the problem.

Hope this helps.

Quote
Juergen Bucher wrote:
> Hello All,

> I have the following problem:

> we wrote a programm using Paradox Databases. In Novell-networks
> we have no problem running the program.
> In NT-Networks (NT4.0 SP3) we get sometimes INDEX-Errors, but only in
> networks with more than 3 workstations. Does anyone know this Problem?
> Please answere!

> Thanks

> Jrgen Bucher
> --
> _-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-
> Fuessl und Bucher
>                  SOLUTIONS for a WIDE WORLD
>                                             call 0049-731-710666

--
Dave Robinson
Amber Computer Systems Inc.

WEB page: http://www.acsi.bc.ca/
Delphi Components Page: http://www.acsi.bc.ca/comp01.html

Other Threads