Board index » delphi » Vendor init failure w/ Oracle & BDE5

Vendor init failure w/ Oracle & BDE5

I installed D4 C/S after uninstalling D3.  I then
tried to run an exising Delphi app I wrote and it can no longer find my
Oracle server (Vendor Initialization Failed).  I restored my IDAPI32.CFG
file and that did not help.  I uninstalled D4 and deleted the BDE directory.
I reinstalled but this time did not install the SQLLinks driver for Oracle 8
(or any other SQL Links drivers for that matter) thinking it might be the
culprit.  Problem persits.

I verified that object Mode = FALSE
I verified that I can get to the Oracle files from Delphi (by placing
SQLPlus in the Delphi/Bin directory and passsing a query {Tip from Borland
support when they were still Borland to verify OraHome path is set
properly})
I verified that the DLL32 and Vendor Init properties were still correct
(SQLORA32.DLL & ORA72.DLL)
I compared the Oracle Configuration and Alias Definintion with another D3 PC
and all is correct.

What could be wrong?
Your help or ideas would be greatly appreciated.  Thanks

 

Re:Vendor init failure w/ Oracle & BDE5


On Wed, 22 Jul 1998 08:46:54 -0400, "Marty Cullen"

Quote
<Marty.Cul...@DataDynam.Com> wrote:
>I installed D4 C/S after uninstalling D3.  I then
>tried to run an exising Delphi app I wrote and it can no longer find my
>Oracle server (Vendor Initialization Failed).  I restored my IDAPI32.CFG
>file and that did not help.  I uninstalled D4 and deleted the BDE directory.
>I reinstalled but this time did not install the SQLLinks driver for Oracle 8
>(or any other SQL Links drivers for that matter) thinking it might be the
>culprit.  Problem persits.

>I verified that object Mode = FALSE
>I verified that I can get to the Oracle files from Delphi (by placing
>SQLPlus in the Delphi/Bin directory and passsing a query {Tip from Borland
>support when they were still Borland to verify OraHome path is set
>properly})
>I verified that the DLL32 and Vendor Init properties were still correct
>(SQLORA32.DLL & ORA72.DLL)
>I compared the Oracle Configuration and Alias Definintion with another D3 PC
>and all is correct.

>What could be wrong?
>Your help or ideas would be greatly appreciated.  Thanks

1. You must have a DOS path that points to those DLLs, and to
\orawin95\bin and to your BDE

2. There is another DLL required by Oracle SQLNET, but I don't
remember the name of it.  Use the TNSPING.EXE program in \orawin95\bin
(put your Oracle instance name on the command line).  If something is
wrong, it will normally give you a good error message.  If this works,
then BDE should also work.

Eric

Re:Vendor init failure w/ Oracle & BDE5


Eric,
  Thank you for your reply.

As I stated in my posting I have double and triple checked the path
statement for my OraHome.  The D:\ORAWIN95\BIN directory is in the path and
not truncated from being too long.  I had a problem one time where my path
statement got altered and I was instructed to copy PLUS32.EXE into the
*\Delphi\Bin directory.  If I can access the database this way the oracle
path is functioning correctly.  I have and it is.

This PC has been working fine with Delphi 3 and BDE 4.x.  The problem
occurred when I uninstalled D3 and installed D4.

Any ideas what could be wrong?

Other Threads