Board index » delphi » Quickreport 2.0j form does preview but not print

Quickreport 2.0j form does preview but not print

Hi,

I have a problem with one Quickreport form in my project.
I have a page header, a footer, a title and a detail band.
When I place something on all bands except the detail band, the printer
output is
the same as the preview.
When I put a QRMemo or a QRLabel on the detail band and fill it
using the OnNeedData event everything shows fine in the preview,
but on the printer output the title- and the detailband are empty!!!

What is the problem?

 

Re:Quickreport 2.0j form does preview but not print


Most likely you have a counter variable which is not getting reset after
the preview. If this is the case then your onneeddata event will behave
differently in the print method from the preview method. If possible do
all your setting up in the beforeprint method so it gets called before
preview and again before printing.

John

Re:Quickreport 2.0j form does preview but not print


Hi John,

THANKS A LOT !!!!!!!!!!!!!!!!!!!!!!
That was the tip I needed, I am sitting here since two weeks and don't know
what
is wrong, but with your help I fixed the problem and the app is ready to
ship :-)))
I Think Quickreport in general is a good reporting tool and I liked using it
but
due to the lack of a good documentation it is not easy to learn Quickreport.

Quote
John M. Philip wrote:
> Most likely you have a counter variable which is not getting reset after
> the preview. If this is the case then your onneeddata event will behave
> differently in the print method from the preview method. If possible do
> all your setting up in the beforeprint method so it gets called before
> preview and again before printing.

> John

Other Threads