Interbase causing server connection problems on SBS2K Server?

Quote
> Overlapped I/O operation is in progress.

Sounds like you're running an older version of Interbase (i.e. 5.x).  I'd
suggest upgrading to either the 6.0.2.0 Open Edition or 6.5 certified.
Older versions were not certified to run on Win2K.  I'm not sure if that
will fix your problem, but it's a step in the right direction.

Dan

Quote
"Tiran Irani" <ti...@qil.co.uk> wrote in message

news:3db026db$1@newsgroups.borland.com...
Quote
> Hi (Apologies for the length of this)

> I have a customer running an application that uses Interbase as the
> underlying database. The application used to be hosted on a W98 PC. We
have
> recently moved it onto a Windows SBS2000 server we have been having
serious
> problems with user connections to the server. There have been numerous
> problems with the application even when running on W98.

> Something seems to happen whilst the app is running that causes the
> workstations to loose the connection to the server. The server, in most
> cases, seems to be functioning ok but there have been occasions where the
> app has hung and the server needs to be rebooted before the workstations
can
> login again.

> Also, when the server boots the Interbase Server and Interbase Guardian
> services fail with the following:

> Event Type: Error
> Event Source: Service Control Manager
> Event Category: None
> Event ID: 7023
> Date:  18/10/2002
> Time:  10:30:37
> User:  N/A
> Computer: XROADS01
> Description:
> The InterBase Server service terminated with the following error:
> Overlapped I/O operation is in progress.

> Event Type: Error
> Event Source: Service Control Manager
> Event Category: None
> Event ID: 7023
> Date:  18/10/2002
> Time:  10:30:37
> User:  N/A
> Computer: XROADS01
> Description:
> The InterBase Guardian service terminated with the following error:
> Overlapped I/O operation is in progress.

> The Interbase log file also has messages such as:

> XROADS01 (Server) Wed Oct 16 16:22:21 2002
>  INET/INET_connect: gethostbyname failed, error code = 11001

> XROADS01 (Server) Fri Oct 18 10:04:47 2002
>  INET/inet_error: read errno = 10054

> XROADS01 (Client) Fri Oct 18 10:30:33 2002
>  C:\Program Files\InterBase Corp\InterBase\bin\ibserver.exe : The guardian
> was unable to launch the server thread. errno : 1056

> XROADS01 (Client) Fri Oct 18 10:31:29 2002
>  Guardian starting: C:\Program Files\InterBase
> Corp\InterBase\bin\ibserver.exe

> Has anyone experienced anything like this elsewhere?

> Thanks
> Tiran