Board index » delphi » BDE Admin - Vendor initialization failed

BDE Admin - Vendor initialization failed

Hi

I created an alias using MSSQL drivers, and tried to connect (NATIVE) to my
database on MSSQL SERVER, and got a message :

Vendor initialization failed.
Connot load an IDAPI Service library
File: NTWDBLIB.DLL

The ODBC for SQL7 is installed, by i didn't install the SQL7 utilities
incluing the client network configuration.

Connecting with ODBC to the same database succeeded.
When i installed the SQL7 untilities, the connection (NATIVE) succeeded,
what it mean is that if i need to connect to the database by NATIVE way, i
have to install the SQL7 utilities.

Is there another simple way to do so ( without configuring and using the
odbc DSN).

Thanks

 

Re:BDE Admin - Vendor initialization failed


I believe that DBLIB is part of the SQL Server client installation.

--
Bill Todd (TeamB)
(Questions received via email cannot be answered.)

Re:BDE Admin - Vendor initialization failed


On Wed, 31 May 2000 10:54:59 +0100, "Rabeh Mansour"

Quote
<khkha...@netvision.net.il> wrote:
>When i installed the SQL7 untilities, the connection (NATIVE) succeeded,
>what it mean is that if i need to connect to the database by NATIVE way, i
>have to install the SQL7 utilities.

>Is there another simple way to do so ( without configuring and using the
>odbc DSN).

The problem has to do with Microsoft's support (or lack there of) for their
DBLIB interface tool.  This interface was the MS prescribed interface to
their SQL Server,  but MS has not fully updated it for SQL Server v7,  so
it still has all of the dependencies of the older SQL Server installations.
This includes the requirement for the MS Client utilities to provide the
proper connection definitions...

I have had some partial success using the MDAC 2.0 ODBC drivers and not
installing the SQL Server client,  but that still required the installation
and configuration of the ODBC drivers,  which is not always a simple
task...

Jerry Bloomfield (TeamB)
--
http://www.teamb.com                                      JersW...@wwa.com
Please do *NOT* send private e-mail without prior permission (my anti-spam
filters will probably just delete it anyway <g>)

Other Threads