Board index » delphi » BDE Error $2A04

BDE Error $2A04

I use Delphi 2.0.
If the property Active of a TTable Component in a form := False, when I
execute under Delphi there is no error (the table is open in the program)

If I put Active: True there is no error in the design but if I execute this
error occurs : $2A04 BDE initialisation problem ?

Any ideas ?
Regards,
J-F

--
* Jean-Francois PEtit  E-mail : Jean-Francois.Pe...@if.insa-lyon.fr *
* I.N.S.A. Departement Informatique                                 *
*    L3I   Laboratoire d'Ingenierie de l'Informatique Industrielle  *
* Bat. 502 20, avenue Albert Einstein   Phone : (33/0)4 72 43 83 75 *
* F-69621 VILLEURBANNE CEDEX  FRANCE    Fax   : (33/0)4 72 43 85 18 *

 

Re:BDE Error $2A04


|>I use Delphi 2.0.
|>If the property Active of a TTable Component in a form := False, when I
|>execute under Delphi there is no error (the table is open in the program)
|>
|>If I put Active: True there is no error in the design but if I execute this
|>error occurs : $2A04 BDE initialisation problem ?
|>
|>Any ideas ?
|>Regards,
|>J-F
|>

You have not properly install borland database engine.  Look in your book for
have to properly install on another computer.

Re:BDE Error $2A04


I am using D1 and encountered something similar to what you have described. The error I got was BDE Error $FFFF and this was
triggered when trying to set the TTable.Active := True at runtime. I suspect that the TableName property of your TTable component w
as probably pointing to a view instead of a database table, e.g. user1.CUSTOMER instead of dbo.CUSTOMER where dbo is the owner of
the table, and a view called CUSTOMER is defined as select * from dbo.CUSOTMER. In this example, you should set the TableName
property to dbo.CUSTOMER.

Hope this helps.

Sincerely,
Simon Ang.
si...@clarity.com.sg

 * * * * Original Message * * * *
In article <5q2p0j$...@tempo.univ-lyon1.fr> Jean-Francois Petit of INSA de Lyon writes:

I use Delphi 2.0.
If the property Active of a TTable Component in a form := False, when I
execute under Delphi there is no error (the table is open in the program)

If I put Active: True there is no error in the design but if I execute this
error occurs : $2A04 BDE initialisation problem ?

Any ideas ?
Regards,
J-F

--
* Jean-Francois PEtit  E-mail : Jean-Francois.Pe...@if.insa-lyon.fr *
* I.N.S.A. Departement Informatique                                 *
*    L3I   Laboratoire d'Ingenierie de l'Informatique Industrielle  *
* Bat. 502 20, avenue Albert Einstein Phone : (33/0)4 72 43 83 75 *
* F-69621 VILLEURBANNE CEDEX  FRANCE    Fax   : (33/0)4 72 43 85 18 *

 * * * * End Original Message * * * *

Other Threads