Board index » delphi » Delphi 2.0 and Windows NT 4.0 beta

Delphi 2.0 and Windows NT 4.0 beta

Hi,

I'm developing on the Windows NT 4.0 beta 2 platform and there is a problem
with delphi 2.0 installing components. Every time i try to install a
component delphi compiles the components an then when delphi is trying to
register them the following error message appears:

cannot open component library c:\programs\borland\delphi
2.0\bin\cmplib32.dcl (error code 998)

Doing the same way under Windows 95 runs correctly.

Can anybody help me ?

thanks, Mike

--
Michael Schwarzl
Softwareentwicklungen
A-5023 Salzburg
Schwa...@MSSE.co.at

 

Re:Delphi 2.0 and Windows NT 4.0 beta


I've installed new components with Delphi 2 under NT 4.0B2 a couple of
times with no problems at all.  This is with the updated D2, I don't know
if the original would behave differently.  Probably not what you wanted to
hear, but it works fine here...

Michael Schwarzl <Schwa...@MSSE.co.at> wrote in article
<01bb8566$10b3d540$0bab51c1@pentium>...

Quote
> I'm developing on the Windows NT 4.0 beta 2 platform and there is a
problem
> with delphi 2.0 installing components. Every time i try to install a
> component delphi compiles the components an then when delphi is trying to
> register them the following error message appears:

Re:Delphi 2.0 and Windows NT 4.0 beta


Quote
In article <01bb8566$10b3d540$0bab51c1@pentium>, "Michael Schwarzl" <Schwa...@MSSE.co.at> wrote:
>Hi,

>I'm developing on the Windows NT 4.0 beta 2 platform and there is a problem
>with delphi 2.0 installing components. Every time i try to install a
>component delphi compiles the components an then when delphi is trying to
>register them the following error message appears:

>cannot open component library c:\programs\borland\delphi
>2.0\bin\cmplib32.dcl (error code 998)

>Doing the same way under Windows 95 runs correctly.

>Can anybody help me ?

>thanks, Mike

>--
>Michael Schwarzl
>Softwareentwicklungen
>A-5023 Salzburg
>Schwa...@MSSE.co.at

Known problem.  People whom I trust at Borland have asserted all these
problems are absent with the released-to-manufacturing version of NT 4.

Jim.

_______________________________________________________________________
James A. O'Brien, Director of R&D
Performance Trading Technologies, Inc. (PTTI)      Makers of The Profile Analyzer (tm)
HQ:  1501 Third Avenue, 4th Floor, New York, NY 10028      +1 (212) 517-1662
R&D:  132 Cherry Hill Road, Orange CT 06477      +1 (203) 891-8333
Wiz...@PTTI.com      http://www.PTTI.com

Re:Delphi 2.0 and Windows NT 4.0 beta


Quote
In article <01bb8566$10b3d540$0bab51c1@pentium>, "Michael Schwarzl" <Schwa...@MSSE.co.at> wrote:
>Hi,

>I'm developing on the Windows NT 4.0 beta 2 platform and there is a problem
>with delphi 2.0 installing components. Every time i try to install a
>component delphi compiles the components an then when delphi is trying to
>register them the following error message appears:

>cannot open component library c:\programs\borland\delphi
>2.0\bin\cmplib32.dcl (error code 998)

Error 998 is Invalid Address to Memory location ( ERROR_NOACCESS)

Hope this helps a little

R.E. den Braasem (aka The Graphical Gnome)

Senior Software Engineer

Re:Delphi 2.0 and Windows NT 4.0 beta


In article <01bb8566$10b3d540$0bab51c1@pentium>,

Quote
"Michael Schwarzl" <Schwa...@MSSE.co.at> wrote:
>I'm developing on the Windows NT 4.0 beta 2 platform and there is a problem
>with delphi 2.0 installing components. Every time i try to install a
>component delphi compiles the components an then when delphi is trying to
>register them the following error message appears:
>cannot open component library c:\programs\borland\delphi 2.0\bin\cmplib32.dcl (error code 998)

Doing the same way under Windows 95 runs correctly.
I think you're running out of memory.
I used to get the same problem under Windows 95 till I realised that this was
occuring because I didn't have enough swap space, and it worked after I freed
up some space on my swap drive.
I suppose you get this problem only under nt because it requires more mem than
95.

Re:Delphi 2.0 and Windows NT 4.0 beta


Quote
Michael Schwarzl wrote:

> I'm developing on the Windows NT 4.0 beta 2 platform and there is a problem
> with delphi 2.0 installing components. Every time i try to install a

Someone at the BDC told me if you shutdown Delphi 2.0, rename comlib32.dcl to
something else and then change it's name back it will work just fine.  Give it
a try.

--
John

jdev...@interaccess.com
See a Poi Dog Pondering on a Sea and Cake!

Re:Delphi 2.0 and Windows NT 4.0 beta


Quote
John DeValk wrote:

> Michael Schwarzl wrote:

> > I'm developing on the Windows NT 4.0 beta 2 platform and there is a problem
> > with delphi 2.0 installing components. Every time i try to install a

> Someone at the BDC told me if you shutdown Delphi 2.0, rename comlib32.dcl to
> something else and then change it's name back it will work just fine.  Give it
> a try.

Allow me to follow up.  The proper way to fix this is to copy (not move) the
file to another directory, delete the original, then move the copy back to
Delphi 2.0/Bin.  That should solve your problem.

--
John

jdev...@interaccess.com
See a Poi Dog Pondering on a Sea and Cake!

Other Threads