Board index » delphi » Cannot re-install Delphi 4

Cannot re-install Delphi 4

I uninstalled Delphi 3 on an NT4 (SP4) workstation and then installed Delphi
4 as administrator.  The user then logged in as herself and tried to install
the Delphi 4 SP 2 and got an error.  I logged in as administrator and
successfully installed the 2 patches.  When the user logged in and ran
Delphi she didn't have any components -- I now understand this problem, but
at the time I didn't so I logged back in as admin and uninstalled Delphi.
When I try to reinstall it, nothing happens.  The Interbase and
InstallShield installs work, but the Delphi 4 install option does nothing.

Keith

 

Re:Cannot re-install Delphi 4


Keith,

    I recommend you try first copying the Delphi install files to the root
directory of a local drive (those would be the runimage directory, install
directory and the root directory on the CD).  It might also be recommendable to
restart in VGA mode and then attempt to run the install program.  Hopefully all
should go smoothly after that.  Please remember to do a 'Registry keys only'
install for each user.

Yarry Gonzalez
Delphi Developer Support
Borland

Quote
Keith Law wrote:
> I uninstalled Delphi 3 on an NT4 (SP4) workstation and then installed Delphi
> 4 as administrator.  The user then logged in as herself and tried to install
> the Delphi 4 SP 2 and got an error.  I logged in as administrator and
> successfully installed the 2 patches.  When the user logged in and ran
> Delphi she didn't have any components -- I now understand this problem, but
> at the time I didn't so I logged back in as admin and uninstalled Delphi.
> When I try to reinstall it, nothing happens.  The Interbase and
> InstallShield installs work, but the Delphi 4 install option does nothing.

> Keith

Re:Cannot re-install Delphi 4


Quote
Yarry Gonzalez (Borland) wrote in message <378BB61F.26CB6...@inprise.com>...
>Keith,

>    I recommend you try first copying the Delphi install files to the root
>directory of a local drive (those would be the runimage directory, install
>directory and the root directory on the CD).  It might also be
recommendable to
>restart in VGA mode and then attempt to run the install program.  Hopefully
all
>should go smoothly after that.  Please remember to do a 'Registry keys
only'
>install for each user.

>Yarry Gonzalez
>Delphi Developer Support
>Borland

I did this and it worked.  Then I ran the Delphi 4 SP2 but I had to abort
because there wasn't enough disk space.  After I cleared up some space and
rebooted, the SP2 installation won't run.  I uninstalled Delphi, figuring to
start all over again, but now I can't run the Delphi install from the local
drive (where it had previously worked) or from the CD.  I either get no
response when I try to run the installs or an hourglass for a couple
seconds, then nothing.  I checked the Event Viewer to see if any messages
were being generated, but nothing there.  FWIW, after trying to run the
installs, I find the ntvdm.exe process is taking 99% of the CPU cycles in
the Task Manager.

I'd be interested in any ideas you have on this matter (or if anyone else
has run into something like this), but it's not a real critical issue, as
I'm thinking that NT may have gone south on this workstation, and it is
usually much easier to reinstall NT than to fix it.

Keith

Re:Cannot re-install Delphi 4


Hi Keith,

I think you may be right about this.  It sounds like the lack of disk space
has caused some other problems that may not be repairable.  I have not heard
of a similar case, so this leads me to the probable conclusion that you
have.  If you can re-install NT, that may be the fastest solution to your
problem.  Be sure to download the latest video drivers for your video card
before you try to install the products.  Good luck!

"It did work
It doesn't work anymore
Windows is like that"

R/S Aaron Rhodes
Delphi Technical Support

Quote
>I did this and it worked.  Then I ran the Delphi 4 SP2 but I had to abort
>because there wasn't enough disk space.  After I cleared up some space and
>rebooted, the SP2 installation won't run.  I uninstalled Delphi, figuring
to
>start all over again, but now I can't run the Delphi install from the local
>drive (where it had previously worked) or from the CD.  I either get no
>response when I try to run the installs or an hourglass for a couple
>seconds, then nothing.  I checked the Event Viewer to see if any messages
>were being generated, but nothing there.  FWIW, after trying to run the
>installs, I find the ntvdm.exe process is taking 99% of the CPU cycles in
>the Task Manager.

>I'd be interested in any ideas you have on this matter (or if anyone else
>has run into something like this), but it's not a real critical issue, as
>I'm thinking that NT may have gone south on this workstation, and it is
>usually much easier to reinstall NT than to fix it.

>Keith

Other Threads