Board index » delphi » email appearing in header

email appearing in header

Hi

I have a small database with e-mail addresses, which I use for sending
out individual e-mails with D6 Indy (8.0.3 ?). My problem is the name of
the first recipient in the database can be seen in all other e-mails
(when I look at properties in OE) like I have shown below:

Received: from dual866 (62.242.60.210[62.242.60.210])by UD15(MailMax
3.073) with ESMTP id 8798977 for <uffe.kousga...@get2net.dk>; Thu, 10
Jan 2002 10:50:48 +0100 RST

First recipient in the database is uffe.kousga...@get2net.dk, while this
was send to my other address u...@routeware.dk - second record in
database. Can anybody tell me which property to change to avoid this
behaviour? I assume some blank property is updated when the first e-mail
is sent and then it stays like that for the next e-mails.

TIA
Uffe

 

Re:email appearing in header


This is a function of the mail server that received the message for
delivery. Some do it and some don't. The 'for <email address>' comes from
the SMTP envelope. The address put in the Received: line like this by mail
servers that do it is from the RCPT-TO: command during the smtp
'handshake' - this is often called the smtp envelope. You really have no
control over it unless you control the mail server and can change this
behavior there.

Quote
"Uffe Kousgaard" <u...@routeware.dk> wrote in message

news:3c3d6679$1_2@dnews...
Quote
> Hi

> I have a small database with e-mail addresses, which I use for sending
> out individual e-mails with D6 Indy (8.0.3 ?). My problem is the name of
> the first recipient in the database can be seen in all other e-mails
> (when I look at properties in OE) like I have shown below:

> Received: from dual866 (62.242.60.210[62.242.60.210])by UD15(MailMax
> 3.073) with ESMTP id 8798977 for <uffe.kousga...@get2net.dk>; Thu, 10
> Jan 2002 10:50:48 +0100 RST

> First recipient in the database is uffe.kousga...@get2net.dk, while this
> was send to my other address u...@routeware.dk - second record in
> database. Can anybody tell me which property to change to avoid this
> behaviour? I assume some blank property is updated when the first e-mail
> is sent and then it stays like that for the next e-mails.

> TIA
> Uffe

Other Threads