Board index » delphi » NT 4 and BDE 2.52 problem

NT 4 and BDE 2.52 problem

Hi,

Is anybody out there using the combination 16 bit Delphi 1 & BDE 2.52 &
Paradox with database installed on a NT 4 server and the program on a NT 4
workstation?

Is there a more recent BDE which I could update to and still use Delphi 1?

The reason I'm asking is this:

I have an Delphi 1 -application using BDE 2.52 and a Paradox database. It
has been working fine on many different Windows OS:s (3.1, 95, 98, NT 3.x).

Now the program is installed on a Windows NT 4 workstation. As long as the
database is located on the workstation everything is fine, but copying the
database to a NT 4 server and changing the alias path to point to the new
location creates a problem. The program can see the database files, but it
seems it can't read them. I get an error similar to the files being read
only.

The database file attributes are OK, and the user is logged with
administrator rights, so there should not be a 'read only' problem.

The problem is not with my application because the problem remains with
third party tools I tested.

If I share the database directory on the workstation and try using it from
another workstation, the problem is the same. It only works when the
database is installed locally.

Any suggestions greatly appreciated,

Christian Lundstrom
c...@laatu.com

 

Re:NT 4 and BDE 2.52 problem


Oh yes, the error message was

"Multiple .NET files in use."

Christian

Re:NT 4 and BDE 2.52 problem


Configure all applications to use the same .net directory. Normally the NET
DIR option in the BDE should be set to the same location as the database.
You can also change the NET DIR at runtime by changing the
Session.NetFileDir property before opening ANY databases (I don't know if
this option was available in Delphi 1).

"Christian Lundstr?m" <cl....@kolumbus.fi> schreef in bericht
news:8vtc3j$50j$1@news.kolumbus.fi...

Quote
> Oh yes, the error message was

> "Multiple .NET files in use."

> Christian

Re:NT 4 and BDE 2.52 problem


The problem is that I can't access the database at all, even with only one
user.
I tried Sundial Service's Chimneysweep 2.02; it can see the files but it
can't process them.

The only protocol installed is TCP/IP. Could this be the problem?

--
Christian

Quote
"M.H. Avegaart" <avegaartNOS...@mccomm.nl> wrote in message

news:8vte97$2g1$1@porthos.nl.uu.net...
Quote
> Configure all applications to use the same .net directory. Normally the
NET
> DIR option in the BDE should be set to the same location as the database.
> You can also change the NET DIR at runtime by changing the
> Session.NetFileDir property before opening ANY databases (I don't know if
> this option was available in Delphi 1).

> "Christian Lundstr?m" <cl....@kolumbus.fi> schreef in bericht
> news:8vtc3j$50j$1@news.kolumbus.fi...
> > Oh yes, the error message was

> > "Multiple .NET files in use."

> > Christian

Re:NT 4 and BDE 2.52 problem


Reboot and delete the current .net file (if nobody is using the database it
is problably a remainder of a system crash).

"Christian Lundstr?m" <cl....@kolumbus.fi> schreef in bericht
news:8vteg9$6md$1@news.kolumbus.fi...

Quote
> The problem is that I can't access the database at all, even with only one
> user.
> I tried Sundial Service's Chimneysweep 2.02; it can see the files but it
> can't process them.

> The only protocol installed is TCP/IP. Could this be the problem?

> --
> Christian

> "M.H. Avegaart" <avegaartNOS...@mccomm.nl> wrote in message
> news:8vte97$2g1$1@porthos.nl.uu.net...
> > Configure all applications to use the same .net directory. Normally the
> NET
> > DIR option in the BDE should be set to the same location as the
database.
> > You can also change the NET DIR at runtime by changing the
> > Session.NetFileDir property before opening ANY databases (I don't know
if
> > this option was available in Delphi 1).

> > "Christian Lundstr?m" <cl....@kolumbus.fi> schreef in bericht
> > news:8vtc3j$50j$1@news.kolumbus.fi...
> > > Oh yes, the error message was

> > > "Multiple .NET files in use."

> > > Christian

Re:NT 4 and BDE 2.52 problem


Quote
Christian Lundstr?m wrote:

> Oh yes, the error message was

> "Multiple .NET files in use."

That is a standard error message with every BDE version.

Use Windows FIND to find and delete every PDOXUSRS.NET and PDOXUSRS.LCK
files there are. Check your BDE settings, to which directory the NET DIR
setting is pointing. On every workstation and server/workstation it should
point to the same directory that resides on the server.

Also, forget both the LongFileNames and UNC file notations when running
D1 apps on NT. Othervise, the BDE 2.52 version is the lates one, and runs
fine both on NT and W2000 networks.

MArkku Nevalainen

Other Threads