Board index » delphi » NT Service + automation object

NT Service + automation object

How I can instill an automation object into a NT service?
I try: New -> Service Application, then New -> Automation object. Then type
MyService /install. It doesn't work. Servise is started by client's call,
but after it started buttons Start/Stop in a Service managere became
disabled.
I think, I do this incorrectly - in dcomcnfg button Identity/The system
account (services only) is disabled. What's wrong?
Max
 

Re:NT Service + automation object


Hi,

You could read the article about services and automation on
my site. It is a serious problem and it can't be described
in details here. In a couple of words: the Delphi ComServ
unit that contains implementation of automation core is
incompatible with SvcMgr unit that implements the services
framework. One of possible solutions of this problem is my
SvCom components. Refer to my site for details.

e??,

Alexey Dynnikov <al...@chat.ru>
http://members.tripod.com/~aldyn
http://al.irt.ustu.ru/~aldyn/
http://www.chat.ru/~aldyn/
SvCom - The Joy of Services

? ??????? <o...@viniti.msk.su> ???Y ?????
???Y??:7qdjsn$59...@forums.borland.com...

Quote
> How I can instill an automation object into a NT service?
> I try: New -> Service Application, then New -> Automation
object. Then type
> MyService /install. It doesn't work. Servise is started by
client's call,
> but after it started buttons Start/Stop in a Service
managere became
> disabled.
> I think, I do this incorrectly - in dcomcnfg button
Identity/The system
> account (services only) is disabled. What's wrong?
> Max

Other Threads