Board index » delphi » "At beginning of Table"

"At beginning of Table"

Hello there, ive just started with a database application in Delphi. I
have a problem adding records to a database and then displaying these
records in a dbgrid. I get the error "At beginnning of table" whenever
i try to click on the record that i just added in the grid. Anyone ?

thanx&bye
email reactions please

Scout Kirk Olson
lo...@euronet.nl

 

Re:"At beginning of Table"


Is there a good book or any other source available that shows in detail
how to call and make use of the Windows API or Win32 API functions?

There is a book for Visual Basic called "Programmers Guide to the Win32
API" by Daniel Appleman. Is there such a thing for Delphi 2.0?

--
Thomas Jaeger
CZAR Software
http://www.execpc.com/~czarsoft

Re:"At beginning of Table"


lo...@euronet.nl (Scout Kirk Olson) wrote:

Quote
>Hello there, ive just started with a database application in Delphi. I
>have a problem adding records to a database and then displaying these
>records in a dbgrid. I get the error "At beginnning of table" whenever
>i try to click on the record that i just added in the grid. Anyone ?
>thanx&bye
>email reactions please
>Scout Kirk Olson
>lo...@euronet.nl

Did you Post the row to the database?

Re:"At beginning of Table"


In article <31f7ada9.5104...@news.euro.net> lo...@euronet.nl (Scout Kirk Olson) writes:

Quote
>From: lo...@euronet.nl (Scout Kirk Olson)
>Subject: "At beginning of Table"
>Date: 27 Aug 1996 00:25:54 GMT
>Hello there, ive just started with a database application in Delphi. I
>have a problem adding records to a database and then displaying these
>records in a dbgrid. I get the error "At beginnning of table" whenever
>i try to click on the record that i just added in the grid. Anyone ?
>thanx&bye
>email reactions please
>Scout Kirk Olson
>lo...@euronet.nl

Kirk:

I need more info - what kind of database are you using?  Are you using the
autoedit property on the datasource or are you explicitly calling the insert
and post methods for the table?  Are you even using a ttable or a tquery to
insert the data?

-Dave

Re:"At beginning of Table"


You've got a blob or memo field in this grid, don't you?  I've had
the same problem, but haven't seen a way to fix it yet.  Instead, I
just disallow in-place editing (kinda defeats the purpose of using
a dbgrid I know, but what can I do?).

 In article
<krajcard.68.32248...@ohsu.edu>, krajc...@ohsu.edu

Quote
(krajc...@ohsu.edu) writes:
>In article <31f7ada9.5104...@news.euro.net> lo...@euronet.nl (Scout Kirk Olson) writes:
>>From: lo...@euronet.nl (Scout Kirk Olson)
>>Subject: "At beginning of Table"
>>Date: 27 Aug 1996 00:25:54 GMT

>>Hello there, ive just started with a database application in Delphi. I
>>have a problem adding records to a database and then displaying these
>>records in a dbgrid. I get the error "At beginnning of table" whenever
>>i try to click on the record that i just added in the grid. Anyone ?

>>thanx&bye
>>email reactions please

>>Scout Kirk Olson
>>lo...@euronet.nl

>Kirk:

>I need more info - what kind of database are you using?  Are you using the
>autoedit property on the datasource or are you explicitly calling the insert
>and post methods for the table?  Are you even using a ttable or a tquery to
>insert the data?

>-Dave

Other Threads