Board index » delphi » Has anyone had any success with SAPI?

Has anyone had any success with SAPI?

I'm currently trying to use SAPI.
I have downloaded and installed the SAPI wrapper from Jedi, and it
works fine from on the Microsoft Sapi5 voice.

The trouble is I need to use it with the Rhetorical Systems Sapi
voice, and although I can select and use this voice with all the
Microsoft Sapi examples, it refuses to work with the Jedi wrapper. It
just reports the engine has not been started.

Has anyone ever seens this with the Jedi wrapper, or does anyone have
any suggestions?

I have tried comparing the C++ source for the MS demos that do work
with the Delphi Jedi demo that doesn't, but I just ended up with a
headache!

Dodgy.

 

Re:Has anyone had any success with SAPI?


Quote
> I'm currently trying to use SAPI.

I dont know anything about it, but here is a SAPI example:

http://codecentral.borland.com/codecentral/ccweb.exe/listing?id=17841

Regards,

Wayne Sherman
Las Vegas

Re:Has anyone had any success with SAPI?


On Wed, 19 Jun 2002 00:52:36 -0700, "Wayne Sherman" <body1233 at yahoo
dot com> waffled on about something:

Quote
>> I'm currently trying to use SAPI.

>I dont know anything about it, but here is a SAPI example:

>http://codecentral.borland.com/codecentral/ccweb.exe/listing?id=17841

Thanks for that Wayne, I'll have a look.

Pity the guy decided to include the MS SAPI SDK in the download...
9.2meg... Eeeeck!

Re:Has anyone had any success with SAPI?


On Wed, 19 Jun 2002 00:52:36 -0700, "Wayne Sherman" <body1233 at yahoo
dot com> waffled on about something:

Quote
>> I'm currently trying to use SAPI.

>I dont know anything about it, but here is a SAPI example:

>http://codecentral.borland.com/codecentral/ccweb.exe/listing?id=17841

Thanks for the link Wayne, unfortunately after a 9meg download it's
just an exe, no source.

Other Threads