Board index » delphi » BDE/Paradox Network updates

BDE/Paradox Network updates

Hello all,

I have been using a simple Paradox based BDE database, which I am now trying
to use over a network.
It sort of works, but changes made on one workstation (say "A") are not
reflected on another ("B") until the table in question is closed and
reopened on B.  Have set up the remote paradox.net file etc.  Doing a
refresh does not seem to help either.  Is this usual, or am I missing
something...

Thanks
Chris Were (kine...@ihug.co.nz)

 

Re:BDE/Paradox Network updates


Hallo there,

I think you are having problems with the <uhhhh what was it called>
Well, anyway, you should use the idle time in a timer to write the changes to the disk.

If this could be usefull for you, please mail me at home and I will look it up for you...

Your's

Marcel van eijkel
eij...@hetnet.nl
it-student

Chris Were (Kinetic Engineering) (kine...@ihug.co.nz) wrote:
: Hello all,

: I have been using a simple Paradox based BDE database, which I am now trying
: to use over a network.
: It sort of works, but changes made on one workstation (say "A") are not
: reflected on another ("B") until the table in question is closed and
: reopened on B.  Have set up the remote paradox.net file etc.  Doing a
: refresh does not seem to help either.  Is this usual, or am I missing
: something...

: Thanks
: Chris Were (kine...@ihug.co.nz)

Re:BDE/Paradox Network updates


In article <68utjv$gh...@newsource.ihug.co.nz> "Chris Were (Kinetic Engineering)" <kine...@ihug.co.nz> writes:

Quote
>From: "Chris Were (Kinetic Engineering)" <kine...@ihug.co.nz>
>Subject: BDE/Paradox Network updates
>Date: Wed, 7 Jan 1998 16:42:08 +1300
>Hello all,
>I have been using a simple Paradox based BDE database, which I am now trying
>to use over a network.
>It sort of works, but changes made on one workstation (say "A") are not
>reflected on another ("B") until the table in question is closed and
>reopened on B.  Have set up the remote paradox.net file etc.  Doing a
>refresh does not seem to help either.  Is this usual, or am I missing
>something...
>Thanks
>Chris Were (kine...@ihug.co.nz)

Dear Chris,
     I had symptoms like those you report (and worse) until I was told to set
LocalShare to true in the BDE configuration.  If you read the help on
LocalShare, the change seems unnecessary, even wrong.  Don't accept this.  
I ran an experiment to confirm that LocalShare=true is required.  I'm running
D2 on a Paradox database.  Networking is via Windows 95.  When I reported my
observations, someone else ran an experiment on a "true" network (Novell, as I
recall) and found that LocalShare=true is not necessary.

I hope I've helped.
                               John.

Other Threads