Board index » delphi » Problem connecting to Interbase Server on NT 4.0

Problem connecting to Interbase Server on NT 4.0

Hi Guys!

I desperately need help with this problem.

I have done the following:

1) Installed Interbase on NT 4.0.

2) Installed Interbase local on win95 workstation.

3)Setup my SERVICES file on both NT and WIN95.
    gds_db           3050/tcp                  # Borland InterBase Server

4)Setup the HOSTS file with the Server IP address and Domain.
    Is this entry compulsary?

5) Ping my Server and TCP/IP SEEMS TO WORK FINE.

6) I see the server on the network and can access it.

7) I setup an alias to access the Interbase Database.I know the path
    is correct because I browsed the network to get to the database.

7) When I try to access an Interbase Database on the NT Server, I get the
following message:

Database Engine Error
    Unknown database
    I/O error for file "\fatdata\Nnovaglob.gdb"
    Error while trying to open file.
    The system cannot find the path specified.
    Alias: DocAssistCommon

The Details to this error message are:
    BDE Error: 10014        [$27][$1E]
    Unknown database

    BDE Error: 13059        [$33][$ 3]
    Server Error: -902
    I/O error for file "\fatdata\Nnovglob.gdb"
    Error while trying to open file
    The system cannot find the path specified.

    BDE Error: 10014        [$27][$1E]
    Alias: DocAssistCommon

I have installed Interbase Server before and it worked like a dream.

I had a hard drive crash, now I am battling.

I can't take it any more AAAAAAAAHHHHHHHHHHHHHHHHHHH!

Please help!!!!

Thanx!

Shaheed

 

Re:Problem connecting to Interbase Server on NT 4.0


Hi,

My guess is you shouldn't install the Local Interbase on the client. You
should use a ODBC connection to the NT server. A Local Interbase server
can't find a database on another computer! Remove the local server and set
up a odbc client.

if it works, send me an email.

good luck!

--
Martijn Tonies
http://surf.to/seal97

Quote
> 1) Installed Interbase on NT 4.0.
> 2) Installed Interbase local on win95 workstation.
> 3)Setup my SERVICES file on both NT and WIN95.
>     gds_db           3050/tcp                  # Borland InterBase Server
> 4)Setup the HOSTS file with the Server IP address and Domain.
>     Is this entry compulsary?
> 5) Ping my Server and TCP/IP SEEMS TO WORK FINE.
> 6) I see the server on the network and can access it.
> 7) I setup an alias to access the Interbase Database.I know the path
>     is correct because I browsed the network to get to the database.
> 7) When I try to access an Interbase Database on the NT Server, I get the
> Database Engine Error
>     Unknown database
>     I/O error for file "\fatdata\Nnovaglob.gdb"
>     Error while trying to open file.
>     The system cannot find the path specified.
>     Alias: DocAssistCommon

Other Threads