Board index » delphi » Vendor Initialization Failed, BDE Error 15879 on NT WS4

Vendor Initialization Failed, BDE Error 15879 on NT WS4

Hi,

I am linking my BDE up to a database on a SQL 2000 platform, using an alias.

In my BDE, I have set up the server name, my server login name and my DataBase name. When i try to test my connection from the BDE itself, i get the following error. "Vendor Initialization Failed" BDE error code is : 15879.

Off Windows 2000 and 98 and 95 this setup works fine but i am only having this trouble on an NT 4 Workstation platform.

Any help would be greatly appreciated,
Thanks in advance,
Rob

 

Re:Vendor Initialization Failed, BDE Error 15879 on NT WS4


Aren't you having a message about a missing dll file too? I had problems with the ntwdlib.dll.
If it's that, copy it from another machine into the \system directory.

Quote
Rob wrote:
> Hi,

> I am linking my BDE up to a database on a SQL 2000 platform, using an alias.

> In my BDE, I have set up the server name, my server login name and my DataBase name. When i try to test my connection from the BDE itself, i get the following error. "Vendor Initialization Failed" BDE error code is : 15879.

> Off Windows 2000 and 98 and 95 this setup works fine but i am only having this trouble on an NT 4 Workstation platform.

> Any help would be greatly appreciated,
> Thanks in advance,
> Rob

--
Guillermo Casta?o Acevedo
Gerente de Sistemas - Grupo Millennium Ltda
Guiller...@GrupoMillennium.com
www.GrupoMillennium.com

Re:Vendor Initialization Failed, BDE Error 15879 on NT WS4


Hi,

Thanks for the info.

But i managed to sort it out, what i did is install the client network utility of Sql Server 2000 onto the client machine.

It worked after that, i might be off base but i think the version of MDAC on that pc was outdated and installing the client network utility updated MDAC.

Keep well,
Rob

Guillermo =?iso-8859-1?Q?Casta=F1o?= A <Guiller...@GrupoMillennium.com> wrote:

Quote
>Aren't you having a message about a missing dll file too? I had problems with the ntwdlib.dll.
>If it's that, copy it from another machine into the \system directory.

>Rob wrote:

>> Hi,

>> I am linking my BDE up to a database on a SQL 2000 platform, using an alias.

>> In my BDE, I have set up the server name, my server login name and my DataBase name. When i try to test my connection from the BDE itself, i get the following error. "Vendor Initialization Failed" BDE error code is : 15879.

>> Off Windows 2000 and 98 and 95 this setup works fine but i am only having this trouble on an NT 4 Workstation platform.

>> Any help would be greatly appreciated,
>> Thanks in advance,
>> Rob

>--
>Guillermo Casta?o Acevedo
>Gerente de Sistemas - Grupo Millennium Ltda
>Guiller...@GrupoMillennium.com
>www.GrupoMillennium.com

Other Threads