Board index » delphi » Paradox 7 Autoincrement field

Paradox 7 Autoincrement field

Hello,
I've got a strange problem with an autoincrement field.
My query looks like this:

select * from orders
where supplier=:supno;

The DataSource property of this query points to a datasource connected
to the 'suppliers' database. The supno field is an autoincrement field.
This worked nicely when suppliers was a Paradox V5 table, but since I
changed it to a V7 table, Delphi says 'field 'supno' is of an
unsupported type' ?!?

Any ideas? Or is this just a bug?

Greetings,
Bruno

--
          Bruno Van Wilder
                    Hewlett-Packard Research Labs, Bristol
                              E-mail: b...@hplb.hpl.hp.com
                                        Tel. +44-117-92 29548
           "Today is the first day of the rest of your life"

 

Re:Paradox 7 Autoincrement field


Bruno Van Wilder <b...@hplb.hpl.hp.com> wrote:

Quote
>> My query looks like this:

>> select * from orders
>> where supplier=:supno;

>> The DataSource property of this query points to a datasource connected
>> to the 'suppliers' database. The supno field is an autoincrement field.
>> This worked nicely when suppliers was a Paradox V5 table, but since I
>> changed it to a V7 table, Delphi says 'field 'supno' is of an
>> unsupported type' ?!?

I think you have to go back into the Object Inspector PARAMS property,
and set the SUPNO to INTEGER

...Bob
btul...@walrus.com
bob.tul...@genie.com (PC Alad / GfW Support)
NYC

Other Threads