Board index » delphi » Serious paradox problems (data coruption and losses, aargh)

Serious paradox problems (data coruption and losses, aargh)

I am writing a claims management program in delphi using a paradox
backend.  unfortunately I am having major problems.  Currently two
computers access the database.  The net directory on both is set to
F:, a shared directory on a third computer that holds the data.  i am
frequently getting the message "Unable to open detail table" on
starting the program on a second computer, if the table has been
openned on the first (note, this is not consistant, sometimes it opens
ok on both computers at once) and getting at least once a day the
message "Index is out of data".  Tables are getting corrupted and data
is being lost.  The database is now Paradox 7 (was 5 with the same
problems) and all three computers are running Windows 95.  Any help
greatly appreciated.

Replies by email if possible, living on the edge of the world means
that newsgroup replies can take up to a week.

Thanks

Sean

 

Re:Serious paradox problems (data coruption and losses, aargh)


Quote
Sean Cross wrote:

> I am writing a claims management program in delphi using a paradox
> backend.  unfortunately I am having major problems.  Currently two
> computers access the database.  The net directory on both is set to
> F:, a shared directory on a third computer that holds the data.  i am

The *.NET file directory must be shared by the two computers, too.

Quote
> frequently getting the message "Unable to open detail table" on

This is usually from not setting the IDAPI network configuration correctly.

Quote
> starting the program on a second computer, if the table has been
> openned on the first (note, this is not consistant, sometimes it opens
> ok on both computers at once) and getting at least once a day the
> message "Index is out of data".  Tables are getting corrupted and data

Probably "Index is out of DATE". This is another common error from an incorrectly set up network
configuration. The table needs to be rebuilt, try TUtility.

Quote
> is being lost.  The database is now Paradox 7 (was 5 with the same
> problems) and all three computers are running Windows 95.  Any help
> greatly appreciated.

1) All computers running the app must have their *.NET file location specified in the IDAPI (BDE)
configuration. They must point to the same location. On a pier-to-pier network I have heard that
the PATH must be the same too. (The drive letter can differ)

2) The machines must have create-read-write-delete access to this directory.

If you still have problems send me a note.

Cheers,

Matthew
==================================================================
Matthew McDermott
McDermott Enterprises
matt...@valleynet.com
My Web Page: http://www.valleynet.com/~matthew
------------------------------------------------------------------
Director of Information Services & Adjunct Professor - Mathematics
The American College of Prehospital Medicine: http://www.acpm.edu/
==================================================================

Other Threads