Board index » delphi » Delphi 7:dbExpress for sybase 1.2 doesn't work properly

Delphi 7:dbExpress for sybase 1.2 doesn't work properly


2004-12-10 11:31:48 AM
delphi145
According to the Sample,I changed the username ,password and server etc.I
even add the DBMS param.
When I choose the SQLConnection.connected to true, it doesn't raise any
error.
But when I use SQLQuery in order to show a table,it raises errors,saying no
such column:(
I'm sure my SQL string would be correct.It seems it still doesn't connect to
the sybase server(ASE 11.9.2)
Is there any other parameter I should add?
ps:if it connected successfully,will it show the tables or procedures in
CommandText? Now I couldn't see anything in that property
 
 

Re:Delphi 7:dbExpress for sybase 1.2 doesn't work properly

Hi,
Borland Sybase driver for dbExpress and has been certified with Sybase 12.5
only.
Please download our dbExpress driver for Sybase ASE from
www.visoco.com/products/dbexpress/ and try our tech support !
Best regards,
VISOCO Software Team
-----------------------------------------
VISOCO Software - Sybase connectivity product
Borland Technology Partner
www.visoco.com
mailto:XXXX@XXXXX.COM
"murphy" <XXXX@XXXXX.COM>сообщи?сообщила ?новостях следующе?
Quote
According to the Sample,I changed the username ,password and server etc.I
even add the DBMS param.
When I choose the SQLConnection.connected to true, it doesn't raise any
error.
But when I use SQLQuery in order to show a table,it raises errors,saying
no
such column:(
I'm sure my SQL string would be correct.It seems it still doesn't connect
to
the sybase server(ASE 11.9.2)
Is there any other parameter I should add?

ps:if it connected successfully,will it show the tables or procedures in
CommandText? Now I couldn't see anything in that property


 

Re:Delphi 7:dbExpress for sybase 1.2 doesn't work properly

In article <XXXX@XXXXX.COM>, XXXX@XXXXX.COM says...
Quote
According to the Sample,I changed the username ,password and server etc.I
even add the DBMS param.
When I choose the SQLConnection.connected to true, it doesn't raise any
error.
But when I use SQLQuery in order to show a table,it raises errors,saying no
such column:(
I'm sure my SQL string would be correct.It seems it still doesn't connect to
the sybase server(ASE 11.9.2)
Is there any other parameter I should add?

ps:if it connected successfully,will it show the tables or procedures in
CommandText? Now I couldn't see anything in that property

I've sucessfully used dbxOpenODBC drivers with ASE 11.9.2 as well as with
ASA 7 and 8 and MS SQL 2000. (Using D7E).
https://sourceforge.net/projects/open-dbexpress/
DO NOT use the "latest file releases" - these are version 2.012 from
December 2003. The current working versions are only available through
CVS (V3.023 from 2004-11-08).
There is a demo project used to test the library - it will allow you to
connect to Sybase through ODBC - it will display a list of tables etc,
you can execute SQL within the demo as well.
Cheers,
EdB