Board index » delphi » why does post not always post?

why does post not always post?

Hello,

I've got a problem I can't solve :
.post does NOT always complete the post. When I look at the database the same
sessions (without quiting delphi) the data is complete, but after a restart
all the data is gone. The strange thing is it doesn't always dissappear.

The database is in insert mode (after calling append).

Can anyone help me out on this.

Rob

 

Re:why does post not always post?


I've been having a bit of trouble with this too....
As suggested in a recent posting on the group, TTables and TQueries have an
"UpdateMode" property which you can set using the Object Inspector.  Its
SUPPOSED to be something to do with FINDING records with SQL according to
the Help file.  However setting this to 'UpdateWhereChanged' seems to help
prevent changes to records disappearing mysteriously......

There is also TDBEDataset.FlushBuffers which is meant to write all updates
(whether or NOT you are using cached updates) to the specified dataset.  I
got some funny glitches with a look-up field not working when I used
this...

Let me know if this helps - I'm basically trying to solve the same problem.
--
Best Regards
Noel Paterson
REMOVE the 'zz' to mail me back.
(Trying to avoid spams)

Fred_Blok <so...@euronet.nl> wrote in article
<socav.13.000C1...@euronet.nl>...

Quote
> Hello,

> I've got a problem I can't solve :
> .post does NOT always complete the post. When I look at the database the
same
> sessions (without quiting delphi) the data is complete, but after a
restart
> all the data is gone. The strange thing is it doesn't always dissappear.

> The database is in insert mode (after calling append).

> Can anyone help me out on this.

> Rob

Re:why does post not always post?


In article <01bdc165$a287ac20$27c448c2@noel-s-pc>, Noel Paterson

Quote
>There is also TDBEDataset.FlushBuffers which is meant to write all updates
>(whether or NOT you are using cached updates) to the specified dataset.  I
>got some funny glitches with a look-up field not working when I used
>this...

Could you expand on this please?

TIA
--
Jeremy Collins
Kansai Business Systems

(return address not altered 'coz I get spammed *whatever* I do!)

Re:why does post not always post?


Hi,

This is problem has actually been addressed by this newsgroup many times.
I've also taken advantage many times of all the help offered through this
group.

Anyway, try using the BDE method: DbiSaveChanges(). Though I'm not sure
anymore whether it's the correct method name, but something similar should
exist in BDE. Try using the BDE help file to locate the exact syntax for the
method. You can use this when closing the form that have your dataset
components.

Good luck.

Lucas

Re:why does post not always post?


On 6 Aug 1998 09:59:12 GMT, so...@euronet.nl (Fred_Blok) wrote:

Try a DBISAVECHANGES(myTable.Handle). Now the data will be written at
once. You have to include the bde-unit.

Best regards

Hansjoerg Posch

Quote
>Hello,

>I've got a problem I can't solve :
>.post does NOT always complete the post. When I look at the database the same
>sessions (without quiting delphi) the data is complete, but after a restart
>all the data is gone. The strange thing is it doesn't always dissappear.

>The database is in insert mode (after calling append).

>Can anyone help me out on this.

>Rob
> -------------------------------------------------------------
> NEU: NEWSGROUP-ARTIKEL ONLINE LESEN, BEANTWORTEN ...
> http://www.hp-software.com/Newsbroker
> -------------------------------------------------------------

Other Threads