Board index » delphi » Graphics System Error: Device Driver file not found (EGAVGA.bgi)

Graphics System Error: Device Driver file not found (EGAVGA.bgi)

When i tried to develop a program to show some graphics by using VGA mode in a console window, the program informed me with following error msg: "Graphics System Error: Device Driver file not found (EGAVGA.bgi)". Then i thought i should set DEVICE=C:\TC\BGI\EGAVGA.bgi in my config.sys, so it would be loaded when needed. But as soon as i restarted my PC, win95 wouldnt load anymore. So i had to undo my changes in the config.sys, and now  i still cant execute my program. Does anyone know how to fix my problem??

 

Re:Graphics System Error: Device Driver file not found (EGAVGA.bgi)


The problem is that:
1) EGAVGA.bgi is not a DOS device driver but a BGI graphic driver
2) try to add
SET BGI=C:\TC\BGI\
in your AUTOEXEC.bat file
or but all BGI related files (i.e. EGAVGA.bgi, *.CHR) and the program in the
same directory

"PredeX" <MP_Samu...@hotmail.com> a crit dans le message news:
3b656888$1_2@dnews...

Quote

> When i tried to develop a program to show some graphics by using VGA mode

in a console window, the program informed me with following error msg:
"Graphics System Error: Device Driver file not found (EGAVGA.bgi)". Then i
thought i should set DEVICE=C:\TC\BGI\EGAVGA.bgi in my config.sys, so it
would be loaded when needed. But as soon as i restarted my PC, win95 wouldnt
load anymore. So i had to undo my changes in the config.sys, and now  i
still cant execute my program. Does anyone know how to fix my problem??

Re:Graphics System Error: Device Driver file not found (EGAVGA.bgi)


Look at the docs on the initgraph function.  The last argument is the path
to the driver.  If the argument is "" then it assumes the driver is in the
same directory as the program.

.  Ed

Other Threads