Board index » delphi » Data Provider or other service returned an E_Fail status error

Data Provider or other service returned an E_Fail status error

Hi,

I am having a big problem with my app after installing D5 (BDE bde511en.exe
installed) on W2000 Advanced Server + SP1.
The problem is a "Data Provider or other service returned an E_Fail status"
error message on opening any tADOQuery and tADOTable.

Using SQL Navigator I am able to query my data. This tells me my DSN is
correct.

If you need more info please let me know. Hope someone will be able to help
me.

Regards,
Ronan van Riet

 

Re:Data Provider or other service returned an E_Fail status error


In article <39f00028_1@dnews>, "Ronan van Riet" <reply to the newsgroup>
says...
Quote
> Hi,

> I am having a big problem with my app after installing D5 (BDE bde511en.exe
> installed) on W2000 Advanced Server + SP1.
> The problem is a "Data Provider or other service returned an E_Fail status"
> error message on opening any tADOQuery and tADOTable.

> Using SQL Navigator I am able to query my data. This tells me my DSN is
> correct.

My win98 problem went away with a reinstall of mdac 2.5, which is
supposed to be uneeded on W2000?  But maybe you need 2.6?  Just guessing.

I wish I had a W2k  advanced server to play with <grin>.

Ron

Re:Data Provider or other service returned an E_Fail status error


Yes, installing the latest MDAC 2.6 fixed all my problems.

Regards,
Ronan van Riet

Quote
"bgood" <nospam_rclaib...@hotmail.com> wrote in message

news:MPG.145cddc85ecbcb0c9896b9@forums.inprise.com...
Quote
> In article <39f00028_1@dnews>, "Ronan van Riet" <reply to the newsgroup>
> says...
> > Hi,

> > I am having a big problem with my app after installing D5 (BDE
bde511en.exe
> > installed) on W2000 Advanced Server + SP1.
> > The problem is a "Data Provider or other service returned an E_Fail
status"
> > error message on opening any tADOQuery and tADOTable.

> > Using SQL Navigator I am able to query my data. This tells me my DSN is
> > correct.

> My win98 problem went away with a reinstall of mdac 2.5, which is
> supposed to be uneeded on W2000?  But maybe you need 2.6?  Just guessing.

> I wish I had a W2k  advanced server to play with <grin>.

> Ron

Other Threads