Board index » delphi » State icons don't appear in Treeview.

State icons don't appear in Treeview.

Hi,
   here's a problem which is baffling me - any ideas about it?  I have a
tree view with a state image list.  The tree view won't display any
state icon beyond position 15.  At 16 and above, nothing appears
although the icons are definitely in the image list.
  I'm using Delphi 3 under Win95.  I have heard that IE4 can cause
problems like this, but I've never heard of this exact problem before.

 

Re:State icons don't appear in Treeview.


Quote
Matt Palmer wrote:
>    here's a problem which is baffling me - any ideas about it?  I have a
> tree view with a state image list.  The tree view won't display any
> state icon beyond position 15.  At 16 and above, nothing appears

  I believe this is just a limitation of the Win32 TreeView control --
which means there isn't a way around it without recoding one from
scratch.

Erik

Re:State icons don't appear in Treeview.


I don't think that this is a limitation of the Win32 Treeview (although I'm
not sure).  The reason is that the effect also appears when I use the TreeNT
component, which, as I understand it is a completely recoded treeview
(although I guess it could just be a recoded wrapper to the Win32 control...)

Matt.

Quote
Erik B. Berry wrote:
> Matt Palmer wrote:
> >    here's a problem which is baffling me - any ideas about it?  I have a
> > tree view with a state image list.  The tree view won't display any
> > state icon beyond position 15.  At 16 and above, nothing appears

>   I believe this is just a limitation of the Win32 TreeView control --
> which means there isn't a way around it without recoding one from
> scratch.

> Erik

Re:State icons don't appear in Treeview.


Quote
Matt Palmer wrote:
> I don't think that this is a limitation of the Win32 Treeview (although I'm
> not sure).  The reason is that the effect also appears when I use the TreeNT

  I've did some research into this a few months ago, and I'm fairly sure
it is a bug/limitation/quirk in the Win32 control.  I've never seen any
other explanation for the problem.  If you find out otherwise, please
tell us, because I've seen quite a few other people ask that question.

Erik

Re:State icons don't appear in Treeview.


Yes, it's a limitation in the Win32 control.  I checked MSDN.
Quote
Erik B. Berry wrote:
> Matt Palmer wrote:
> > I don't think that this is a limitation of the Win32 Treeview (although I'm
> > not sure).  The reason is that the effect also appears when I use the TreeNT

>   I've did some research into this a few months ago, and I'm fairly sure
> it is a bug/limitation/quirk in the Win32 control.  I've never seen any
> other explanation for the problem.  If you find out otherwise, please
> tell us, because I've seen quite a few other people ask that question.

> Erik

Other Threads