Board index » delphi » Crashing memo in Delphi (& crashing Paradox 5)

Crashing memo in Delphi (& crashing Paradox 5)

I have the following problem

I have data in my Paradox database. It all worked fine yesterday. Six hours
ago, when I woke up, I got back to my project, and Delphi crashed as soon
as I opened a form, and the previously compiled program didn't work anymore
either.

After six hours trying to recover as much as possible (rather large
project) I found that things go wrong when it needs to display the memo
field. Adding an empty record at the front of the database results into a
working situation. However, when I get to the normal record, my compiled
program crashes again. :-(

I recently acquired Paradox 5 in order to be able to check memo fields of
databases, but this program crashes when it gets started up under Windows
'95.

Can anybody tell me how to solve this problem. I can't lose the data
already in the database, as there is no backup of it. Also info how on
earth this could go wrong. This program has to be finished by Wednesday,
and I can't afford that I give them a not working program.

Thanks in advance. I'll check this newsgroup and my E-Mail every half hour
from now, to see if anybody is able to help.

Marc van Leeuwen
mar...@localaccess.nl

 

Re:Crashing memo in Delphi (& crashing Paradox 5)


Quote
> I have data in my Paradox database. It all worked fine yesterday. Six
hours
> ago, when I woke up, I got back to my project, and Delphi crashed as soon
> as I opened a form, and the previously compiled program didn't work
anymore
> either.

Two suggestions:

1) Your MB file (the bit that stores the memos) of your table is corrupt.

2) If Paradox is crashing at start-up, Windows is corrupt. Did you shut
down properly before hitting the sack? Perhaps a virus? Perhaps you should
run NT ;-)

--

Mark P
-----------
http://www.ozemail.com.au/~pritchma

Other Threads