Board index » delphi » Troubles with Delphi 4 install - TREGSERVR and PackageForTheWeb

Troubles with Delphi 4 install - TREGSERVR and PackageForTheWeb

I'm trying to install Delphi 4 Pro and have received a bunch of errors.
In the initial install, near the very end I got an Av error in
"_ins0432" details told me the error was in kernel32.dll.  Install
seemed to finish fine, so I went through the reboot and as my machine
was coming up, got several screens of TREGSERVR with an error:
"Paramater value is not in allowed range" that flashed briefly on my
screen and went away (I counted 4 or 5 screens of this).  Delphi 4
appeared to come up ok, though.  Downloaded SP2 from the website, and on
trying to run it, I get an error window: "PackageForTheWeb error Corrupt
cabinet file" then the exe dies.

Any help, any ideas?

BTW, I have Delphi 3.02 Client/Server installed on the same machine.

Running under Win 95.

Pam

 

Re:Troubles with Delphi 4 install - TREGSERVR and PackageForTheWeb


Hi Pam,
The corrupt cabinet file error means you didn't download the entire SP2
file or it got corrupted on d/l. Try to download it again, or order the
CD.

As for the installation, it sounds like you had a lot of install
problems. Try completely uninstalling D4, remove any references to it
from the hard drive, and remove any refernces to it from the registry. I
would reccomend doing this even before applying sp2. Restart in safe
mode, and install from there. Note any errors that you get (if any) and
post back.

Corbin

Quote
Pam Abdulla wrote:

> I'm trying to install Delphi 4 Pro and have received a bunch of errors.
> In the initial install, near the very end I got an Av error in
> "_ins0432" details told me the error was in kernel32.dll.  Install
> seemed to finish fine, so I went through the reboot and as my machine
> was coming up, got several screens of TREGSERVR with an error:
> "Paramater value is not in allowed range" that flashed briefly on my
> screen and went away (I counted 4 or 5 screens of this).  Delphi 4
> appeared to come up ok, though.  Downloaded SP2 from the website, and on
> trying to run it, I get an error window: "PackageForTheWeb error Corrupt
> cabinet file" then the exe dies.

> Any help, any ideas?

> BTW, I have Delphi 3.02 Client/Server installed on the same machine.

> Running under Win 95.

> Pam

--
Corbin Dunn
Delphi Developer Support
www.borland.com
(I do not respond to support questions by e-mail)

Re:Troubles with Delphi 4 install - TREGSERVR and PackageForTheWeb


OK, did the uninstall, cleared out all references to Delphi 4 in the
registry, rebooted in safe mode and tried again, this time without
installing InterBase.  Did not get the AV, but on reboot still got those
TREGSRVR windows (this time I was able to count - there were 4 of
them).  Haven't tried re-loading the SP yet.  Should I do that or wait?

(I'm going to a Delphi conference, so it may be a while before I
respond.)

Pam

Quote
Corbin [Inprise] wrote:

> Hi Pam,
> The corrupt cabinet file error means you didn't download the entire SP2
> file or it got corrupted on d/l. Try to download it again, or order the
> CD.

> As for the installation, it sounds like you had a lot of install
> problems. Try completely uninstalling D4, remove any references to it
> from the hard drive, and remove any refernces to it from the registry. I
> would reccomend doing this even before applying sp2. Restart in safe
> mode, and install from there. Note any errors that you get (if any) and
> post back.

> Corbin

> Pam Abdulla wrote:

> > I'm trying to install Delphi 4 Pro and have received a bunch of errors.
> > In the initial install, near the very end I got an Av error in
> > "_ins0432" details told me the error was in kernel32.dll.  Install
> > seemed to finish fine, so I went through the reboot and as my machine
> > was coming up, got several screens of TREGSERVR with an error:
> > "Paramater value is not in allowed range" that flashed briefly on my
> > screen and went away (I counted 4 or 5 screens of this).  Delphi 4
> > appeared to come up ok, though.  Downloaded SP2 from the website, and on
> > trying to run it, I get an error window: "PackageForTheWeb error Corrupt
> > cabinet file" then the exe dies.

> > Any help, any ideas?

> > BTW, I have Delphi 3.02 Client/Server installed on the same machine.

> > Running under Win 95.

> > Pam

> --
> Corbin Dunn
> Delphi Developer Support
> www.borland.com
> (I do not respond to support questions by e-mail)

Re:Troubles with Delphi 4 install - TREGSERVR and PackageForTheWeb


Hi Pam,
Sounds like everything went fine this install. The TREGSVR windows are
normal. Go ahead and install SP2 (3 should be out some time this week,
so you might want to just wait for that.)
Corbin
Quote
Pam Abdulla wrote:

> OK, did the uninstall, cleared out all references to Delphi 4 in the
> registry, rebooted in safe mode and tried again, this time without
> installing InterBase.  Did not get the AV, but on reboot still got those
> TREGSRVR windows (this time I was able to count - there were 4 of
> them).  Haven't tried re-loading the SP yet.  Should I do that or wait?

> (I'm going to a Delphi conference, so it may be a while before I
> respond.)

> Pam

> Corbin [Inprise] wrote:

> > Hi Pam,
> > The corrupt cabinet file error means you didn't download the entire SP2
> > file or it got corrupted on d/l. Try to download it again, or order the
> > CD.

> > As for the installation, it sounds like you had a lot of install
> > problems. Try completely uninstalling D4, remove any references to it
> > from the hard drive, and remove any refernces to it from the registry. I
> > would reccomend doing this even before applying sp2. Restart in safe
> > mode, and install from there. Note any errors that you get (if any) and
> > post back.

> > Corbin

> > Pam Abdulla wrote:

> > > I'm trying to install Delphi 4 Pro and have received a bunch of errors.
> > > In the initial install, near the very end I got an Av error in
> > > "_ins0432" details told me the error was in kernel32.dll.  Install
> > > seemed to finish fine, so I went through the reboot and as my machine
> > > was coming up, got several screens of TREGSERVR with an error:
> > > "Paramater value is not in allowed range" that flashed briefly on my
> > > screen and went away (I counted 4 or 5 screens of this).  Delphi 4
> > > appeared to come up ok, though.  Downloaded SP2 from the website, and on
> > > trying to run it, I get an error window: "PackageForTheWeb error Corrupt
> > > cabinet file" then the exe dies.

> > > Any help, any ideas?

> > > BTW, I have Delphi 3.02 Client/Server installed on the same machine.

> > > Running under Win 95.

> > > Pam

> > --
> > Corbin Dunn
> > Delphi Developer Support
> > www.borland.com
> > (I do not respond to support questions by e-mail)

Other Threads