Board index » delphi » Delphi 2.0 Upgrade BDE problems - Help!

Delphi 2.0 Upgrade BDE problems - Help!

I've been working with Delphi 2.0 since it came out.  Things were
pretty good (nothing's perfect) until I installed the latest 2.0
upgrade.  Now a simple TQuery doesn't work.  The query in question is:
  SELECT CLIENT_ID FROM Request
  WHERE (REQ_LOW <= :REQ_VAL) AND (REQ_HIGH >= :REQ_VAL)

It was working before the new upgrade.  This is with a Paradox 5.0
database.  And the error returned is:
  Access violation at address 4c613e86.  Read of address FFFFFFFF

On our network, my machine, and one other were loaded with the new
version.  These both give the error.  On the ones which are still
running the original 32 bit bde from Delphi 2.0's first release are
still working fine (running the *same* EXE).

Removing the WHERE clause removes the error, but obviously doesn't
help me.

Not using parameterized :REQ_VAL fields doesn't change anything.

Performing just one side of the AND (and removing 'AND ...' doesn't
help.

I have another Query component which DOES still work:
  SELECT * from Requests, Clients
  WHERE Clients.CLIENT_ID = Request.CLIENT_ID
  ORDER BY CLIENT_NAME

And even more frustrating, once I've installed the new BDE on a
machine the problem persists even AFTER uninstalling it and going back
to the earlier BDE..  So, I can't even get it back running once I've
installed the new copy..

Please, Please help if you can, or have any ideas at all,

Thanks in advance,
Tim Gary

ps. Please CC via email if possible as well, my nes server isn't all
that I'd like it to be.. Thanks!

 

Re:Delphi 2.0 Upgrade BDE problems - Help!


On Wed, 31 Jul 1996 20:54:23 GMT, t...@carbon.com (Tim Gary) you
smacked the keyboard repeatedly to write:

[Snip]

Quote

>It was working before the new upgrade.  This is with a Paradox 5.0
>database.  And the error returned is:
>  Access violation at address 4c613e86.  Read of address FFFFFFFF

I've run into a similar error in D2 (not sure if the 4c613e86 is the
same).  What I had to do was delete all files EXCEPT the PAS and DFM
files and recreate the project from scratch.  Then I would recompile
it and the error would go away or it would show me an error that it
didn't pickup because the compiler assumed a file was up to date and
didn't recompile it (Even with a Build ALL).

Brien King
bk...@primenet.com

Re:Delphi 2.0 Upgrade BDE problems - Help!


Quote
Tim Gary wrote:

> I've been working with Delphi 2.0 since it came out.  Things were
> pretty good (nothing's perfect) until I installed the latest 2.0
> upgrade.  Now a simple TQuery doesn't work.  The [snip]

you got off lucky!  I can't even get it on my
machine.  After twenty minutes or so (we'll see
what the phone bill says) with a tech support rep,
I STILL can't get it loaded.  

Anyone else experiencing a similar problem (I'm
running NT 3.51 Service Pack 4, 32Mb P100 with 2Mb
Diamond Viper SVGA card and 1.2Gb of disk)?

Other Threads