Board index » delphi » Delphi 2.0 and Access 2.0

Delphi 2.0 and Access 2.0

I need to get Delphi 2.0 to connect to an Access 2.0 database (Not
Access 95/7.0).  All I need to do is read the data, not write back.

Can somebody please help by providing a step by step guide how to get
Delphi 2.0 to read this access table.

I've tried everything.

Thanks in advance.  email a reply as well as posting if possible.

Rodney Delanty
aa...@ozemail.com.au

 

Re:Delphi 2.0 and Access 2.0


Rodney Delanty <aa...@ozemail.com.au> wrote in article
<344DA5CD.7...@ozemail.com.au>...

Quote
> I need to get Delphi 2.0 to connect to an Access 2.0 database (Not
> Access 95/7.0).  All I need to do is read the data, not write back.

> Can somebody please help by providing a step by step guide how to get
> Delphi 2.0 to read this access table.

> I've tried everything.

> Thanks in advance.  email a reply as well as posting if possible.

> Rodney Delanty
> aa...@ozemail.com.au

Rodney, from what I understand about Access databases, each version's file
format is sufficiently different that you cannot open one version with the
engine or driver of another version.  I've successfully opened a version 5
with version 6 Access, however one really annoying thing is that the
database MUST be converted to the later format, thus making the database
incompatible with the program which is using it.  Catch-22.

I haven't tried this, nor do I know how one would obtain this, but I
imagine that if you have an ODBC driver for Access version 2.0 db's that
you would be able to open the db in your Delphi app without having to
convert the db to a later version.  (Keep in mind you can't use a BDE
native driver because the only one that works for Access is the very latest
version.. prior versions must port from BDE through ODBC).

You might check out MicroSludge's Technet CD set to see if there is an
applicable driver, either that or contact them directly.  I've
heard/experienced that MS doesn't like to support "extinct" wares (they
kick and scream like little children who can't get their way).  They might
withhold ODBC drivers for version 2.0 with the premise being that you
should be buying the newer versions and dumping the old (a marketing scheme
of theirs).

Hope this helps..

--
======================================
click here to send me email.. m...@wascoinc.com
embedded email address in post is a
moronic spammer
======================================

Other Threads